1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

rt1 pump quit help needed..

Discussion in 'Boss Plows Discussion' started by foolforfords, Feb 8, 2014.

  1. foolforfords

    foolforfords Junior Member
    Messages: 22

    my pump isint working as of Thursday. it just quit ,nothing, I replaced the selinoid on the pump itself,but still no go.theres power from the battery to the selinoid but it still isint working. any help would be greatly appreciated.thanks,
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Is there pwr and gnd at the pump?
     
  3. foolforfords

    foolforfords Junior Member
    Messages: 22

    theres power at the selinoid from the battery but idont have power at the motor .the selinoid has three posts theres power at the post from the battery no power at the small post or the other post which goes to the motor stem , sorry im trying to explain this but im no mechanic. I can take pics to explain better
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    You should only have pwr at the small terminal when you press up, left, or right. So you might need an extra hand or a way to keep the controller up. Then test light the solenoid pwr in, signal pwr and then pwr out
     
  5. foolforfords

    foolforfords Junior Member
    Messages: 22

    celanoid pics

    new celanoid not working

    IMG_20140208_163824_319.jpg

    IMG_20140208_163833_696.jpg

    IMG_20140208_163808_900.jpg
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Where's your pwr in off the battery?
     
  7. foolforfords

    foolforfords Junior Member
    Messages: 22

    its the bottom post not seen in the picture ,should there be power at the other posts also such as the short wire from the selinoid to the post on the motor ? and the small yellow wire that goes to the valves
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    What happens when you apply 12v right to the motor?
     
  9. foolforfords

    foolforfords Junior Member
    Messages: 22

    nothing happens so that cant be good !
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    So prob need a motor
     
  11. foolforfords

    foolforfords Junior Member
    Messages: 22

    is there a ground wire im not seeing somewhere ?how is the motor grounded this unit has been trouble free until now
     
  12. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Motor should be grounded through
    A) ground wire directly attached to the case
    B) grounded through the pump
    You should be able to find the wire. Big black cable
     
  13. foolforfords

    foolforfords Junior Member
    Messages: 22

    thanks for your help diesess .more testing in the AM..
     
  14. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,874

    Something isnt right there? I have an RT1 still mounted let me go take a look...
     
  15. foolforfords

    foolforfords Junior Member
    Messages: 22

    anything terrapro?
     
  16. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,874

    Well my solenoid is mounted to the body of my truck for the ground...I dont know I think you have a power problem or a motor problem. Check if you have power coming out from the solenoid and make sure you have power to your controller to activate the solenoid.
     
  17. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,874

    Do you have the rocker switch box for the controller or a stick?
     
  18. foolforfords

    foolforfords Junior Member
    Messages: 22

    I have the box with three switches ,
     
  19. foolforfords

    foolforfords Junior Member
    Messages: 22

    B&B help a guy out here ! any thing else to check or do !!!
     
  20. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Again. You need to have signal at the small wire at the solenoid when you press up, l,or r.
    Test light that wire, then test light pwr out. The other big wire going to the motor
    I asked if you jumped the motor with a pos cable and you said you did and it didn't move that us telling me it needs a plow motor