1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

rt-2 8.3 v plow

Discussion in 'Boss Plows Discussion' started by milwaukeevtwin, Nov 24, 2009.

  1. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335

    Well i went to hook the plow up and got nothing. No lights, Nothing on the plow side. I took jumper cables and attached it to the plow motor and it cranked over? I can here the solenoid clicking but the plow does nothing. Where do i start? Any help would be appreciated.:confused:
     
  2. cameo89

    cameo89 Senior Member
    Messages: 669

    same on mine, I just replaced the solinoid and every thing is fine now, pretty easy fix, but mine also cliked before I replaced it.
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If you don't even have plow lights then it isn't a solenoid issue. More like a ground or power issue on the plow harness.

    1) Start at the battery and check the small brown ground as well as the small red wire for good connections.

    2) Make sure the pins are clean and fit together good in the power cable connector at the bumper.

    3) Next check the black/red wire for 12V. Should run to a fused ignition source inside the truck somewhere.

    That'll get you started.
     
  4. Brian Young

    Brian Young PlowSite Veteran
    Messages: 3,382

    We had a Boss plow at a place I used to work, one year same thing, no power or anything. I pulled the cover off and found the ground wire on the driver side of tower completely fell off. I bolted it back together and all was good.
     
  5. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335

    Plow

    Thanks, Guy's. I will be working on this through out the weekend. I will keep you informed. The problem is the wires have been changed so much i have to start tracing them down.
    Thanks, Ron
     
  6. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335

    Wiring

    Well i went through all the wiring under the hood and found some ugly wiring. I cleaned it all up and installed a new solenoid. Is there a way i can test the truck side? I was wondering if i could attach a wiring light to the to large pins on the harness and get it to light. When i tried i got nothing. Any suggestions? Solenoid clicks. Time to work on cab wiring tomorrow.
    Thanks, Ron:rolleyes:
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Sure you can use a test light on the bumper connector to check operation of every function and light. You can head over the the Boss site and download the manual for the RT2 to learn the pinouts and their respective functions for testing.
     
  8. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335

    Plow

    Bad wire to power in cab. Fixed that and a lot of others, then found a bad ground to the main two pin at the bumper. Still need to do a little tinkering, but for sitting five years. I am amazed. Plow never missed a stroke. Time for maintenance.
    Thanks, Guy's.xysport