1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

remote problem?

Discussion in 'Sno-Way Discussion' started by Bruno, Dec 24, 2008.

  1. Bruno

    Bruno Member
    Messages: 81

    I have a mega blade revolution and the remote started displaying LOST SIGNAL and a long beep. About 2 second later it returns to normal and it becomes functional. Then 30 seconds or minute go by and it starts again. The strange thing is that it not a wireless unit, its wired in.

    Any idea on what i should check first?
  2. kramer56

    kramer56 Senior Member
    Messages: 595

    check and see if everything is hooked tight at front of truck and then go to the reciever module on back side of pump, make sure if all connections are tight, if so then you have a firewall rub on the cord.
    Have you made sure all fuses are pushed in tight or tightened down properly?
  3. Bruno

    Bruno Member
    Messages: 81

    This is so strange,, I passed by my dealer and tried plugging in a new remote to see if the remote was the problem but it did the same thing. Unfortunately my dealer was to busy to get the truck in and actually check it.

    -The remote wire has no cuts or shorts through firewall or along any part of the cable.
    -I have unplugged ever socket and connector possible and sprayed it with WD40 to disapait any moisture that was possible
    -The plow is brand new, only used 4 times. There is no corrosion anywhere.
    -Any wires that the dealer spliced or connected are tight.

    Yesterday it worked fine at the last hour of my route,, thought the problem just decided to leave the same way it came. No such luck, when i got back home i attempted to turn on remote again to see what would happen and it fricken stated again! LOST SIGNAL.

    Whats the possibility of the receiver module be defective or the isolation box.

    Any other idea would be great, Dealer cant look at it for another 4 days.