1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Recon 60" tailgate bar w/amber scanning leds bars are junk

Discussion in 'Strobe Lighting' started by chuckraduenz, Feb 14, 2013.

  1. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    well i got a Recon 60in Tailgate Bar w/ Amber Scanning leds in 2009. bar turned into a titanic and took in water wrecking it only after a few monthes. took a yr to get another from the company.

    got a differnt truck bought another bar Recon 60in Tailgate Bar w/ Amber Scanning leds thinking they changed the quality of there bars. nope. i got a call from the guy where my truck sits. he tells me my tailights are glowing "there on but dim". got to my truck 3days later. and hooked up my trailer. only to find out the trailer brakes are on as well. then found out my tailights are still glowing. well after 2hrs of un plugging fuses for trailer lights, brake lights, running lights for truck and trailer. then i unplugged the 7way trailer plug. and the tailights turned off. hum thought problem solved... well then something said unplug the tailgate bar. AND that was the actual issue..... piles of junk.

    so what kinda tailgate bar do you have? or have you had any issues with recons tailgate bars?????
     
  2. Too Stroked

    Too Stroked Senior Member
    Messages: 555

    I'm not going to disagree with you. I had a brand new Recon bar last all of 2 months - in the summer! Too bad too since I really like the way they look. Good thing I didn't go to all the trouble I usually do and hard wire the POS.
     
  3. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    ya i didnt hard wire any of them. added a sae plug for the 12v + and the reverse lights. and soldered in a trailer plug anda sae plug so everything is just a few zip ties, 5 screws and 2 plugs to remove....

    got an email back saying "does this only happen with the trailer hooked up?"

    i spent 2hrs laying in the snow just to figure out it was a easy as unplugging the trailer. omg please i wouldnt lay in the snow for 2hrs. the first thing i did was unplug the trailer. do the easy stuff first. then get harder into it.

    i will never get another recon bar again....... 3month warranty!!!!!!!!!!!! $150 tailgate bar = positive fail

    im gona try PlasmaGlow 60" FireStorm Tailgate Bar has a 1YR warranty on it. not the chep 3 month warranty.
     
  4. Too Stroked

    Too Stroked Senior Member
    Messages: 555

    I have one of those sitting in my basement. It will not fit under the tailgate of my 2010 F-150. So, it sits waiting for the next truck.
     
  5. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    they have more wires to hook up dont they?
     
  6. Too Stroked

    Too Stroked Senior Member
    Messages: 555

    The one I bought is an all red LED bar if I recall correctly. That's a straight 4 wire hookup.
     
  7. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    i was going to past emails from recon. and i had forgotten about this tailgate bar that has just failed by back feeding is actuly the replacement that i had bought that failed right out of the box.

    so the failure rate is so bad im suprised there sill in business. evon looking on the net theres so many complaints about recon lighting.

    im looking at getting the plasmaglow tailgate bar next.
     
  8. MattyK

    MattyK Senior Member
    from Boston
    Messages: 105

    i had the plasmaglow firestorm scanning light bar in my old truck, I got rid of it after a year because it started acting weird. when i used my directional, it would scan in the correct direction however when i stepped on my brakes then it would scan in the wrong direction. Thought maybe my wires got crossed somehow or something came loose and was touching something else so i rewired the whole thing and it still did it.