1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Radio static with HIDs

Discussion in 'Chevy Trucks' started by William B., Feb 9, 2010.

  1. William B.

    William B. Senior Member
    from S.E. IA
    Messages: 978

    I've been fighting this problem some since I installed my HIDs about a month ago. I'm getting really bad static on a couple radio stations when my HIDs are on and I'm not sure how to correct it. I've heard remount the ballasts away from something metal. which is really hard to do on the front end of these trucks. Especially seeing as they come with a metal bracket to hold the ballast in place. Little help would be appreciated.
     
  2. aaronlampi

    aaronlampi Junior Member
    from 55445
    Messages: 15

    hid problem

    try grounding the input wire that feeds the hid instead of the factory harness.by doing this you isoulate the ground from the factory harness to the battery.
     
  3. 496 BB

    496 BB Senior Member
    Messages: 789

    What brand are they? DDM?

    Its usually the ballast that are bad when this happens. Ive been using VVME altely with no probs at all. I got a weird setup now though on the HD.
     
  4. William B.

    William B. Senior Member
    from S.E. IA
    Messages: 978

    They are VVME. I emailed them and they said to use this stuff. I'm not sure what it is or where to get it.

    silver_paper.jpg
     
  5. 496 BB

    496 BB Senior Member
    Messages: 789

    Looks like aluminum foil tape. Can be found at local hardware store. They say to wrap ballast in it?