1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Question on E60

Discussion in 'Meyer / Diamond Products Discussion' started by tsmith, Dec 6, 2008.

  1. tsmith

    tsmith Senior Member
    Messages: 255

    I am wondering if this is normal or not. I have an E60 pump I just put on a month ago and have a Slick Stic on it. When I angle it all the way right or left it starts to pick up after it angles all the way. Is this normal or not? I've never had an E60 before, my E47 never did that.
  2. dirtmandan2

    dirtmandan2 Senior Member
    Messages: 274

    My e 60's don't do that...
  3. tsmith

    tsmith Senior Member
    Messages: 255

    Thanks, I didn't think it was normal. Now I just gotta figure why it does that.
  4. archer39

    archer39 Member
    from PA
    Messages: 62

    mine does not do that either
  5. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    I would start by checking the B valve to make sure the o-rings are good, that its not stuck partially or full shifted and that it does shift.
  6. tsmith

    tsmith Senior Member
    Messages: 255

    Crash, you da man. It was a bad o-ring, the smaller one. Thanks again Crash.
  7. Sydenstricker Landscaping

    Sydenstricker Landscaping PlowSite Veteran
    Messages: 3,882

    Ahh I need to do this to mine then too!!! It does this at times as well. Thanks for this thread!!!:waving: