1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

put new motor on spins like crzy nothin happens

Discussion in 'Western Plows Discussion' started by dheavychevy38, Jan 27, 2009.

  1. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    Just as the title says put a new motor on my unimount to bring it back to life and it just spins won't pick it up or anything you can see it jump a little and that is it. I'm thinkn oring on pump or pump :realmad:
  2. CityGuy

    CityGuy PlowSite Fanatic
    Messages: 16,906

    Did you make sure to line up the internal spot and the shaft? Check your filter? Just first thoughts.
  3. pickles

    pickles Junior Member
    Messages: 3

    will the plow angle left or right?
  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    More than likely you didnt get the pump shaft and motor indexed together.
  5. dheavychevy38

    dheavychevy38 Senior Member
    Messages: 283

    When i first went out everything worked fine. I went to get fuel and when i got home nothin but noise so i first checked the fluid and it was low. I toped it off properly and nothin. With the truck off cause it's a diesel you can hear the motor spinI but the plow won't do anything it might jitter when you first hit the lever but that's it. First thing i am going to check tomorrow is the filter then the o-ring. I had this motor on for two plows then the truck has sat for around a week and a half.
  6. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    likely frozen.