1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Pushes good as far as I'm concerned !!

Discussion in 'ATV / UTV Snow Removal' started by IPLOWSNO, Dec 19, 2015.

  1. IPLOWSNO

    IPLOWSNO PlowSite.com Addict
    Messages: 1,620

    This is actually our second snowfall the first one was a month and a half ago but it was only 9"s and we just played in it

    This is good old heavy ass lake effect though and it can stop anytime now

    http://youtu.be/tgUvnxJRxGI
     
  2. IPLOWSNO

    IPLOWSNO PlowSite.com Addict
    Messages: 1,620

    Oh I do have a problem my winch is just clicking on and off at the junction box,, any ideas on what I need to change?
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,962

    I would say the parts that's bad. But that's just my guess
     
  4. IPLOWSNO

    IPLOWSNO PlowSite.com Addict
    Messages: 1,620

    Very helpful thanks
     
  5. jim331656

    jim331656 Member
    from NJ
    Messages: 44

    I assume you mean the solenoid is clicking but nothing is happening? I had the same issue, cleaned up and/or replaced the connections and it was fine. If not I'd say a new solenoid. Does it go one way but not the other or just not work?
     
  6. IPLOWSNO

    IPLOWSNO PlowSite.com Addict
    Messages: 1,620

    Yes I figured out what the dam thing was called thank you, all it's doing is clicking I will try to clean it up its under the seat so it's in a clean area but I know what you mean by cleaning it lol
     
  7. jim331656

    jim331656 Member
    from NJ
    Messages: 44

    Clean them up with a wire brush if they are corroded, make sure they are crimped on right and the nuts are tight. If the winch isn't doing anything at all you need to make sure voltage is getting to the winch. Check it with a multi meter. Make sure everything is connected and tight both on the winch and the solenoid. Without testing it with a meter, if you are getting clicking at the solenoid that would lead me to believe that the feed from the battery and the switch are ok. Leaving the solenoid itself or the winch being bad or more likely a loose or broken connector or wire.
     
  8. IPLOWSNO

    IPLOWSNO PlowSite.com Addict
    Messages: 1,620

    Yes sir working on it soon!! My new blade is like a dozer blade I got to be able to pick it up lol driveways a mess but it's been regraded lol
     
  9. Chevy2500

    Chevy2500 Junior Member
    Messages: 10

    Looks like it did good!
     
  10. IPLOWSNO

    IPLOWSNO PlowSite.com Addict
    Messages: 1,620

    Thanks, I took that solenoid apart and she didn't do anything ever again lol, got one off eBay for 26 bucks and she still clicked so I removed all the washers and she worked!

    Thank god for the couple inches we've had this year!! I don't care if it don't snow again!! Wood pile is as big as ever with the high temps we've had!!