1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Pump relief valve setting- Insta-Act/MM2

Discussion in 'Fisher Engineering Discussion' started by rtm038, Jan 29, 2007.

  1. rtm038

    rtm038 Senior Member
    from NJ
    Messages: 231

    Hello all,
    I got a 2 or 3 year old (bought it used), 9' X-blade and have noticed that it raises & angles very slowly. According to the manual, one possible reason for slow hydraulics is an improperly adjusted pump relief valve. So I checked the pump relief valve setting and found it be out set around 3 turns from the seated position. According to the manual, the valve should be set around 2 1/2 to 2 3/4 turns, which will set the relief to around 1750 psi. So I turned it all the way in (fully seated), then backed it out 2 3/4 turns. Went to raise the plow and it wouldn't raise more than 1" before the valve opened and cut hydraulic pressure to the lift cylinder. So, I set it for about 2 1/2 turns and it raised it about 5", then quit. Then I set it to around 2 turns and while it raised it, it was slow to do so and it didn't seem to have much "power" behind it. Finally, I set it about 1 1/2 turns and it is perfect. It raises and angles much better and has a good amount of "power" behind it. Is having to set the pump relief valve to this setting (1 1/2 turns) normal or is there possibly something else wrong within the system?

    Any insight here would be greatly appreciated.

  2. LON

    LON Senior Member
    Messages: 749

    did ya throw a gauge on it to tell exactly where it is set?
  3. rtm038

    rtm038 Senior Member
    from NJ
    Messages: 231

    No and I know I should've, but I couldn't find my pressure gauge. I'll do a pressure test on Wednesday. I checked the level of the fluid and it looks to be ATF (red), so that'll need to get changed (looks real dirty too), along with the filter.