1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Pump motor runs but pulled to the right...??

Discussion in 'Western Plows Discussion' started by sheltonct, Dec 31, 2008.

  1. sheltonct

    sheltonct Junior Member
    Messages: 14

    Western 7'6" Uni-mount on 1989 F150 with Heavy duty front end. 6 pin connector but spliced and butt-connected and was working fine...

    It was just fully tuned up - replaced solenoid - pump motor - worked for a day and now this week later - I can hear the pump motor running and lights dimming in truck. Noticed the problem the day it was raining went out side to clear the sludge on the driveway then started this problem. I checked the connection to the plow and noticed a lot of water in the connection - dried out and still the problem - either way, pump motor still running if controller stick is touched.

    Controller stick moved left or right would send the plow blade up or down, now if the controller is touched only goes to the right and now will not move out of this position.

    thanks,
     
  2. sheltonct

    sheltonct Junior Member
    Messages: 14

    please delete - found the problem - the grill connection on the drivrs side - i kept messing with it and it moves slightly.