1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Pump motor getting hot fast.

Discussion in 'Boss Plows Discussion' started by mudhound72, Jan 7, 2015.

  1. mudhound72

    mudhound72 Junior Member
    Messages: 5

    I have a 93 f350 with a older style Boss 9'2" V-plow the one with the pump under the hood. The problem I am having is that the pump gets hot when plowing small areas and slows way down, but in the larger lots were there is a longer time between raising/moving the blade I don't have as much of a problem.

    I am wondering if my pump motor is crapping out on me. The Motor is only a few years old installed by the PO. I installed new cables from the pump to the batteries and the batteries are also a year old and in good shape. So far the best way I have dealt with it was to pack some snow on it to cool it off quicker so I can keep going.

    Any thought on what to do???
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Find out how many amps your pulling,,,,find out your pump psi.
    I would have to guess the motor tho IMO
     
  3. mudhound72

    mudhound72 Junior Member
    Messages: 5

    I am not sure on the amps or PSI, I can check the amps when I have some free time. I am hope that it will last a bit longer then I will get a new motor and throw it into the tool box on the truck just in case. Ideal thing to happen is that it would last the season, I am planning on getting a newer plow for next year.
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    So, your gunna hope that it don't go out. Gunna hope it don't burn up a solenoid, wiring and maybe take out and alternator or battery, over what....150.00 motor?