1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

pto dump not working

Discussion in 'Heavy Equipment' started by andrewlawnrangr, Dec 5, 2009.

  1. andrewlawnrangr

    andrewlawnrangr Senior Member
    Messages: 339

    hello all
    i have a 2006 f-750 with a pto dump. the pto engages and you can hear it and when i go to raise the body i get a straining noise. this is when the body is empty. all pivoit points are greased, hydro oil in tank is good. i think it is the pump. i would like to change the fluid and check if there are screens or filters in line. what would you recomend?

    thanks all andrew

    DGODGR Senior Member
    from s/w co
    Messages: 639

    First, check the oil in the resevoir. Is their any, or is it low? I know it's an obvious suggestion but had to be made. The noise you are hearing is the pump cavitating. This usually happens when oil flow can not meet pump demand. The fact that it doesn't go up suggests no oil.
    Secondly, I would check/replace the filter if it has one. A plugged filter will have the same effect as low/no oil.
    How cold was it when you attempted to raise the bed. If it is really cold out my pump makes the same noises, though it will still go up (not very smoothly). If the oil is old it may have some water contamination (thus making the problem worse). Try to change to an oil that is a lower viscosity (and that will work in lower temps) for winter use. The thinner oil will probably be fine for all seasons, anyway, since I doubt you will run the pump long enough to get the oil hot enough to cause problems.