1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

PS-Cannot go back to last page

Discussion in 'Questions, Rules, Suggestions' started by DHDB, Oct 14, 2011.

Thread Status:
Not open for further replies.
  1. DHDB

    DHDB Member
    Messages: 94

    I am not sure what is going on but I cannot go back to the last page viewed. I have to go back to the main forum and find my way back to a thread. I wasn't sure if anyone else was having this problem.
     
  2. DHDB

    DHDB Member
    Messages: 94

    Seems to be working now.
     
  3. rhkfwain

    rhkfwain Senior Member
    from FWA, IN
    Messages: 304

    This has been an ongoing problem on this site for well over a year now. Many have complained about it.
     
  4. CS-LAWNSERVICE

    CS-LAWNSERVICE Member
    Messages: 79

    yep I have the same problem with this forum ,so not when I go to a topic I just right click it and open in a new tab so I do not loose my place .
     
  5. Kubota 8540

    Kubota 8540 PlowSite.com Addict
    Messages: 1,952

    Some pages work right and some do not it seems.
     
  6. rhkfwain

    rhkfwain Senior Member
    from FWA, IN
    Messages: 304

    It is an intermittent problem for me but frustrating!
     
  7. Michael J. Donovan

    Michael J. Donovan Head Moderator, Online Communities Staff Member
    Messages: 1,051

    it could be the browser you are using, here is a link to where this was dicussed before - http://www.plowsite.com/showthread.php?t=83498

    also, I have tried in IE 8 and IE 9 and am not experiencing the problem with the back button, but will check with the site technicians and let you know if/what the problem may be
     
  8. rhkfwain

    rhkfwain Senior Member
    from FWA, IN
    Messages: 304

    Michael,

    I use the latest version of Firefox.
     
  9. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    I ocasionaly have the issue also on both my IBM with IE8 and my MAC with Safari whatever the latest is.
     
  10. Charles

    Charles Moderator Staff Member
    Messages: 256

  11. wizardsr

    wizardsr PlowSite.com Addict
    Messages: 1,553

  12. Charles

    Charles Moderator Staff Member
    Messages: 256

    Just google Fox Fire back button not working. Lots of hits
     
  13. Championized

    Championized Junior Member
    Messages: 5

    I have the same problem, but only on PlowSite. I'm on Firefox 4, but my back button works everywhere else.
     
  14. Pushin 2 Please

    Pushin 2 Please PlowSite Veteran
    Messages: 4,571

    x2........
     
  15. Championized

    Championized Junior Member
    Messages: 5

    The last day or two my back button has worked fine here on PlowSite, but today is acting up again. I want to add that although on the Firefox link above people said their back button was greyed out, mine is not. When I click on it, it briefly goes through the motions of working, but then stops.
     
  16. cmo18

    cmo18 Senior Member
    Messages: 815

    I as well have problems using the back button only on plowsite...
     
  17. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Mine devolped the stutters, sometimes it goes forward sometime no. If I hit the back button then the forward button it will work again.
     
  18. wizardsr

    wizardsr PlowSite.com Addict
    Messages: 1,553

    This problem is solved! Thanks to CT-TILEMAN!!! Mega props for the info on the Firefox AdBlock Plus plug-in. Added that and this place is like a different site! Easy to use, loads fast, and no more back button problem! Thumbs Up

    Credit where it's due to the mods as well for NOT DELETING CT-TILEMAN's post with this info. Thumbs Up
     
  19. Pushin4U

    Pushin4U Senior Member
    Messages: 145

    X2..... I did that and WOW everything loads 10 times faster and no more back button issues!
    ;)
     
  20. Camden

    Camden PlowSite Fanatic
    Messages: 6,598

    Yep, I installed Ad-Block Plus and now this site works like it should Thumbs Up Thanks to whoever came up with the solution!
     
Thread Status:
Not open for further replies.