1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Problem with Turn Signals

Discussion in 'Boss Plows Discussion' started by SpruceLandscape, Dec 8, 2006.

  1. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Hey everyone. We finally got some decent snow, everything worked great up until today. When I was driving from one job to another, my Left front turn signals stopped working on the plow and the truck. About 4 hours later, same thing on the right side. My marker lights all work fine on the plow and truck, rear lights work as well. I checked all the bulbs on the truck and the markers on the plow, all the filaments are intact. Any ideas? Could this be a relay issue? Or do you think its a fuse issue with the truck? After I dropped the plow, flipped the light switch to TRUCK, but still no front turn signals, even though the markers are working. I'm too tired and cold to go digging up my fuse box tonight to see if I blew a few fuses, but one thing I did notice is that when I checked the marker lights on the plow, there was a small amount of condenstion in the both of them. The one side had the gasket most of the way out of place (must have slipped when I replaced the bulbs this fall). Could there have just been a short from moisture/salt getting into there? Give me some opinions. Thanks, chuck
     
  2. WRIGHTTRAILERS

    WRIGHTTRAILERS Member
    Messages: 38

    There is a known issue related to the turn signals being overpowered by the plow on the 06 and newer dodges. Depending on when your plow was installed, it may have been put on after the issue was discovered. A relay pack has to be installed for the turn signals. It would come as part of the head adapter now. You should contact your dealer regarding it.

    Adam Caron
    Wright Trailers
    Seekonk, Ma
     
  3. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    My plow and harness are from 2005. I took it off of my last truck and then just bought the new headlight adapter kit and undercarriage.
     
  4. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    I had a chance to check all my fuses and they are all good. Only thing left is the relays. Does this sound like something that could be fixed simply by testing the relays and finding a bad one, or is there supposed to be an update to the newer dodge harness's?
     
  5. Jerre Heyer

    Jerre Heyer Senior Member
    Messages: 948

    Bad news is that it's a trip to the dodge dealer to get the computer reset. Dodge says the truck is a HD and that it has a plow prep package but the truck won't handle an extra 1157 or 3157 bulb per side on the front circut. You can do a relay upgrade or change out to LED bulbs for the turn signals. LED's aren't cheap but work great in this application on all plow models.

    I've been fighting with dodge for a while on this issue. Seems that if you have 2 bulbs on your trailer on each side you may have the same problem to the rear so heads up for all you trailer pullers.
     
  6. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    are you talking about changing the plow turnsignals to LED's or the truck's? Is the relay upgrade something for the truck, or is that part of the plow harness?? I would really like to get this figured out before the next big snow.
     
  7. Jerre Heyer

    Jerre Heyer Senior Member
    Messages: 948

    Plow lights...
     
  8. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    UPDATE:
    After having a chance to go up to the dealership where I bought my Headlight adapter kit and undercarriage, they were doing an install on a 06 dodge 2500 CTD. We started comparing the wiring harness, and sure enough, the light kit that I was given, even though the part number was correct, didn't come with the two extra relays that are now specific to this application. MY NEW PROBLEM: Don't have the receipt anymore, just my credit card statement with the purchase on it. Now I have to try to convince BOSS that the kit I had ordered came without the relays, just the 4 light adapters. On top of that, IF they decide to send me the parts I need (not holding my breath) what needs to be done to correct my problem of having no lights still? Probably have to eat the cost of that at the dealership. I see this costing me an extra $65 for a whole new light kit, plus a couple hundred I'm sure at the dealership!:gunsfiring: :gunsfiring: :gunsfiring: :gunsfiring:
     
  9. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Is anyone on here a dealer or work at a BOSS dealership? If so, any way you could talk to a Boss Rep and see if there was some sort of an upgrade to the light kit half way through the year? I'm hoping maybe they sent me an older version because they didn't discover a problem until a certain date. I'm not getting very good feelings from the place that sold me the kit as far as them pressing Boss to help me out. It kinda feels like they don't want to piss off Boss at my expense.
     
  10. starc

    starc Senior Member
    Messages: 229

    You did check to see if the bulb was ok right....
     
  11. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    yes, all the bulbs on the plow and truck are in good condition.
     
  12. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    My right just stopped working last week. The dealer told me about the problem with over powering and having to reprogram as well. What it ended up being was the wire corroded where they tapped into for the plow. They cut the section out, soldered a new one in and it worked fine.
     
  13. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Richard, does your harness have a total of 6 relays on it? 4 on the main harness and two additional for the lights? That seems to be the culprit in my case.
     
  14. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    Im not 100% sure, but Im pretty sure it does. The dealer covered it under warranty. Also, my turnsignal was still working on the plow, just not the truck.
     
    Last edited: Dec 16, 2006
  15. ThisIsMe

    ThisIsMe Senior Member
    from Mass
    Messages: 745

  16. Jerre Heyer

    Jerre Heyer Senior Member
    Messages: 948

    Bad news, this is only for the rear circut not the front circut. They still haven't to my info done a TSB for the flash on the front circut.

    Jerre
     
  17. ThisIsMe

    ThisIsMe Senior Member
    from Mass
    Messages: 745

    Thanks Jerre, you really know how to kill the excitement in a guy. :)

    Anyway, there looks to be some other changes in the code the way the darn thing works. Hopefully the flash will take care of it????? Fingers crossed here.
     
  18. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Hey guys, thanks for the hard work. I am still leaning on the Boss rep to see what they will do for me. So far I have gotten no where other than having to buy ANOTHER light kit that comes with all the parts. I haven't yet taken the truck back to the dealer to see if they can reset it because I want to make sure the harness is correct first so that they don't have a reason to give me a hard time. First dealer I called already told me over the phone that I would be looking at service charges because its just about automatic that the problem is related to the plow harness as far as they are concerned.
     
  19. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    Maybe you should give my dealer for my plow a call. My Dodge dealer was said they were sending some of their turn signal problems there. Maybe they can atleast point you in the right direction. www.gwfab.com they have an 800 # too. It's 1-866-wny-boss Heck it's worth a try.
     
  20. ThisIsMe

    ThisIsMe Senior Member
    from Mass
    Messages: 745

    Even more so, and if I am reading the service manual and the TSB correctly, they can only reset this module 5 times. The 6th time it needs to be replaced.

    So this module acts like a fuse for the signals.But in order to check the fuse or have it replaced, you need to bring it to a dealer. Worse yet you can only replace the "fuse" so many times. I fail to see how technology has progressed here?

    I say put the fuses back.