1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Problem here..

Discussion in 'Truck & Equipment Repair' started by MileHigh, Mar 26, 2010.

  1. MileHigh

    MileHigh PlowSite.com Addict
    Messages: 1,827

    Have had a lot of snow to push here these last several days, with a new storm coming in the afternoon, and now a problem is occurring that I can't figure out on my own.

    Every time I press left, right, or lift the plow up, my radio will shut off real quickly and then turn back on. Float does not cause this. I'm thinking this will progress into a larger problem while I'm plowing this storm.

    I've went through all the connections...

    What the hell?

    It also seems as if my **** doesn't crank as hard?

    Truck is a 04 f250 diesel w/ dual batteries....plow is a hiniker straight.
  2. jb1390

    jb1390 Senior Member
    Messages: 710

    Bad grounds. The radio will kick off due to low voltage. Disconnect and clean all connections. Reassemble with dielectric grease. Problem solved.
  3. MileHigh

    MileHigh PlowSite.com Addict
    Messages: 1,827

    Did what you said and its golden now.

  4. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Glad you fixed it.
  5. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    also check were switched power for the plow is connected.