1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

pro plus raise problems

Discussion in 'Western Plows Discussion' started by Mxrider069, Feb 1, 2013.

  1. Mxrider069

    Mxrider069 Member
    Messages: 85

    i have a 09 model 9 foot pro plus, it was having a problem of slowly leaking down when in the raised position. it would also very slowly angle left if you held up on the controller after it was all the way up. i thought maybe something was stuck in a valve so i pulled them all out and sprayed them with parts cleaner and re assembled. i changed fluid and cleaned everything in the resevoir as well. when it was all together it does not leak down. it still will angle to the left if you hold up when its all the way up. now my problem is that the plow wont raise as fast as it used to and it seems to drop slower as well, it angles side to side just as fast as it used to.

    Truck has 2 new batteries and dual 145amp alternators all connected with 0 gauge wire so i know its not a power problem

    Any imput?? Suggestions..
     
  2. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    Did you accidently screw in the quill valve on the top of the manifold?? This would cause the plow to raise and lower slower. Or there is still a piece of debris in the manifold.
     
  3. Mxrider069

    Mxrider069 Member
    Messages: 85

    no i didnt mess with the quill which is why i dont get it :gunsfiring:
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The S2 valve is sticking partially shifted. May be debris or it's internal spring is broken.
     
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

  6. Mxrider069

    Mxrider069 Member
    Messages: 85

    Filter is clean, tried 4 dif controllers with no change. I switch the s2 valve and it seemed not to much different all tho i havnt plowed with it yet.
     
  7. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    You might have a problem with you "poppet check" valve. There might be something in the passage that will not let it function correctly or it might be damage.

    Also before you switch the S2 valve, did you check the passage way to make sure there nothing interfering with the flow. Also, check S1 (this lower the plow) to make sure it is not sticking or once again, check the passage way to make sure there nothing interfering with the flow.

    The link I put on the last post (#5), download it and look on page #56

    This is a good PDF to keep on hand.
     
  8. Mxrider069

    Mxrider069 Member
    Messages: 85

    I will pull the poppet tomorrow and see what it looks like, whats the most common a broken spring or something?
     
  9. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Yes, the spring. That was the problem in my case