1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

PRO CASTER (need help ASAP!)

Discussion in 'Truck & Equipment Repair' started by mowerman1848, Nov 13, 2014.

  1. mowerman1848

    mowerman1848 Junior Member
    from maine
    Messages: 2

    I just got a used stainless pro caster w/ box control in the cab. There were 3 wires. Power. Ground. And the main cluster (the plug). Started the honda motor with the pull start to make sure it ran and it does. The PROBLEM I am having is the only thing that is working on the controller is the throttle/choke. I can't engage the spinner or start/shut off the motor from the control box.. I am getting power to the solenoid but for some reason nothing to the starter or the elec. clutch? Any ideas?
     
  2. LON

    LON Senior Member
    Messages: 749

    Clutch should be an issue coming from the ignition accessory side. The clutch should have the power cut to it when you turn the key off.
    Engine start comes from the battery on the spreader as power come from the back up into the controller and back to the solenoid. First place I'd look if everything looks ok at the solenoid is the plug-in end (trailer plug). Quite common for wires to be pulled out of their individual sockets.