1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

power ?

Discussion in 'Truck & Equipment Repair' started by PTTP08, Nov 30, 2010.

  1. PTTP08

    PTTP08 Senior Member
    from mn
    Messages: 183

    I just got done plowing for the night truck ran great and so did the plow (I have small jobs) so I don't run all that long. Any way I had to adjust my plow height a lil so I dropped the plow and raised a lil than the amp meter dumped the 8 or 9 amps and the lights dimmed as I sit there driving pooping my pants hoping to make it home then the battery light came on and blinked on and off and etc. than I turned off lights heaters and etc. to save on power than I looked down and it jumped up and it was charging again and everything was ok. I pulled in the nearest parking lot and checked all the connections found the silanoid main battery wires very loose. I tightend then up. I ran the plow after up ,down side to side and it didn't seem to do that again. But is the problem? I was thinking altinator was going out. this truck has a brand spanking new battery in it. It doesn't have dual set up yet but that is in the budget for this year as soon as the first check gets here.

    thanks again for your input!
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    bad connection is your problem.
  3. KL&M Snow Div.

    KL&M Snow Div. PlowSite.com Addict
    Messages: 1,616

    Agreed, bad connection on something. Check your grounds.