1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Power-V won't lift

Discussion in 'Boss Plows Discussion' started by jbmotor, Oct 7, 2007.

  1. jbmotor

    jbmotor Junior Member
    Messages: 1

    Just bought a used 8'2" power v yesterday. It is an RT-3 with smart hitch. I don 't know anything about these plows yet, I'm new to the snowplowing world.
    When the guy had it mounted on his truck, the motor worked and the blade seemed like it wanted to lift up but it didn't. No fluids were spewing out, hydraulic level was fine. The guy told me that the lift solenoid valve is probably defective. What do you guys think? Is there anything else I should look for? Thanks.
  2. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

  3. Camden

    Camden PlowSite Fanatic
    Messages: 6,594

    Did you flip the switch on the side of the light tower after you hooked it up? Sounds to me like that's the problem...
  4. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    If you're trying to hook it up to the truck make sure the plow is in the float position. Hold down the "down position" on the controller till the controllers red light goes on.
  5. FFD133

    FFD133 Senior Member
    Messages: 140

    One of my guys had a problem last season on our largest lot we were plowing. Worked fine for about 15 mins, then plow would not lift. It ended up being that big solenoid that runs from the wiring to the plow from the truck to that solenoid and then to the battery. Takes about 5 minutes to change, he just needed the part. Hopefully that's your problem as it's a pretty easy and inexpensive fix.
  6. Novi plow boy

    Novi plow boy Member
    Messages: 38

    I had the same problem and i thought the smarthitch switch was bad but then found out i had to hold the controller in the down position till the light turned red and the light unit lifted fine to hook into place.
  7. jrglandscape

    jrglandscape Member
    Messages: 40

    I had that problem last year on my 9'2 vee plow ended up being the ground on the lift valve coil. I believe in was the one with the white wire running to it. I just regrounded it, never had a problem since.

    JRG Landscape
  8. noluck

    noluck Junior Member
    Messages: 5

    just wondering how much the 8' 2" cost you. I have been looking for one. I Have a 9' 2" too big for truck ( long story)
  9. FFD133

    FFD133 Senior Member
    Messages: 140

    My 8'2" poly V cost me $5100 installed here in Indy. This was last seasons price. Not sure how much they're running this year.

    How much you looking to sell the 9'2" for?
  10. Midwest BuildIt Inc

    Midwest BuildIt Inc PlowSite.com Addict
    Messages: 1,280

    I have an 8'2",,wanna trade?