1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Power steering

Discussion in 'Chevy Trucks' started by purpleranger519, Feb 8, 2008.

  1. purpleranger519

    purpleranger519 Senior Member
    from Kansas
    Messages: 536

    Just had the power steering go out on my 1998 Chevy 2500 for the 4th time in the past 13 months. twice last winter now twice this winter. Appears to me it only happens when the plow is on the truck. anybody else ever had this problem?
     
  2. Plowinpro03

    Plowinpro03 Senior Member
    Messages: 151

    is the pump breaking or the actual steering box? Im getting worried about mine lately, seems like a HUGE strain on the power steering units. I'm gonna make an assumption and say that your pump is busting, prolly the valves can't hold the "pressure" when your plows up and your turning. The wheel becomes very "stiff", your best bet to avoid this is to gas your truck to give the pump a little more power. Although, that gets very annoying, im gonna see if they make a smaller pulley and replace the original one and get a smaller belt that way its always turning faster.
     
  3. purpleranger519

    purpleranger519 Senior Member
    from Kansas
    Messages: 536

    let me know where you pick the pully up at or what size it is. Im going to do the same
     
  4. purpleranger519

    purpleranger519 Senior Member
    from Kansas
    Messages: 536

    It's the powersteering pump. I thought it was the gear box the second time this happened and replaced it as well.
     
  5. Mark Witcher

    Mark Witcher Senior Member
    Messages: 604

    Are you buying cheap rebuild pumps or a new factory unit?4 pumps in one year , something is not right. Poor pump, poor installation and or both. are you flushing the system before putting on the new pumps? Are you using the correct fluid?
     
    Last edited: Feb 11, 2008
  6. wirenut

    wirenut Senior Member
    from nh
    Messages: 514

    check with gm there is a gear problem in the box
    i had mine in for the gauge problem and the service man
    was telling me about it...mine is a 04
     
  7. purpleranger519

    purpleranger519 Senior Member
    from Kansas
    Messages: 536

    I had them done everytime....chevy did the last 2.
     
  8. Plowinpro03

    Plowinpro03 Senior Member
    Messages: 151

    no luck on a good fit for that pulley yet....if its not the pulley, its the belt size that wont match up well.....dam this is hard..
     
  9. purpleranger519

    purpleranger519 Senior Member
    from Kansas
    Messages: 536

    tell me about it. ive been looking as well.