1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Power Problems

Discussion in 'Western Plows Discussion' started by 07DodgeWestern, Sep 27, 2009.

  1. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    I Just purchased a 2006 Uni Mount Plow to go on my 2007 Dodge Ram, I have installed all the wires and can not get the solinoid to power up. If I hook power straight to the plow it arks. The headlights work and the switch box is powered up. Does anyone have any suggestions?
    I have already changed solinoids with a new one and tried direct connect.

    Thanks
     
  2. Western1

    Western1 Senior Member
    from MI.
    Messages: 679

    Check your grounds. There should be one from the solenoid to the battery.
     
  3. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    I have the soliniod grounded directly to the battery and i still have no power to the plow. whats happening is im not getting power to the red line(to the plow) and no switching motions at the plow.
     
  4. Western1

    Western1 Senior Member
    from MI.
    Messages: 679

    Do you have the red wire hooked to power near the controller? Does the controller light up?
     
  5. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    Yes it is lit up, i have power to the red and the red/yellow wires, and the black is grounded.
     
  6. Western1

    Western1 Senior Member
    from MI.
    Messages: 679

    Is this the isolation module wiring or the relay style? Have you checked out the mechanics guide on the western website?
     
  7. Western1

    Western1 Senior Member
    from MI.
    Messages: 679

    This is a unimount? Do you hookup 2 or 3 connectors at the grill?
     
  8. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    No I havent checked that out. I will check it out and see if it will help
    Thanks
     
  9. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    I have one for power (two prongs, ground and power) One for switch (3 wires, up, left, right) and one for Headlamps (the only thing that is working)
     
  10. Western1

    Western1 Senior Member
    from MI.
    Messages: 679

    There are a couple of connections one near the iso module where the ground connects from one harness to another and near the solenoid where the same occurs are those connected? Just one wire black with orange stripe I think.
     
  11. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    ya they both are i even tried hot wiring them and it didnt make a difference. Im puzzled as to what it could be, someone suggested it could be the iso box itself?!
     
  12. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    You say only the headlights are working, what about the park/turn?

    Go back to the motor solenoid and find the red wire that comes out of harness with the brn/red and red/grn wires, that red wire needs to go on the large terminal with the power cable coming from the battery. Check to make sure that you dont have it on the terminal going out to the plow.
     
  13. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    Yes sorry the signals/park lamps do work, I do have the red/green on the big terminal of the solinoid with the red cable from the battery.
     
  14. Western1

    Western1 Senior Member
    from MI.
    Messages: 679

    Do you know anyone to swap the iso mod to see if that works? I have had harnessess new from western that were bad.
     
  15. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    I do not but I could just go to the service centre and see if they can check it or let me try one. Problem is I cant take the plow with me.
     
  16. Western1

    Western1 Senior Member
    from MI.
    Messages: 679

    You can hook it up and short chain the plow. Let me know if you need a iso mod.
     
  17. Racer593

    Racer593 Member
    Messages: 71

    can you mount the plow, then just jack it up and hook the chain short to drive to the service center?
    Just a thought...

    Chris
     
  18. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    OK thank you
     
  19. Racer593

    Racer593 Member
    Messages: 71

    You must have been sending it while I was typing it!!!

    Chris
     
  20. 07DodgeWestern

    07DodgeWestern Junior Member
    Messages: 17

    Problem solved it was the darn joystick box.