1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plump wont work

Discussion in 'Truck & Equipment Repair' started by ned5485, Nov 27, 2007.

  1. ned5485

    ned5485 Member
    Messages: 36

    I just replaced the pump on my E-47. Got it back on the truck and it lifted fine yhe first try. Now when I try to lift or angle, there is no movement and no "loud growl". It just makes a clicking noise. A single click. I assume the click is a selenoid. It was working about 1 out of 5 times i hit the switch. I have not got the plow to move in the last several tries. I am not sure what to check now. There is plenty of fluid.

    Any ideas? I hope its cheap!
  2. ned5485

    ned5485 Member
    Messages: 36

    It is actually my PUMP that is not working. I have not checked my "plump" yet.
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Check your pm's ned.

    DAFFMOBILEWASH PlowSite.com Addict
    Messages: 1,581

    I'd start off by replacing the solinoid. Just for the simple fact they can act lazy sometimes. Clicking but no powwer transfer. Who knows it may just be from sitting, or it could be the begining of failure. For the 25.00 top of the line you can have the reliability of new. Don't forget the diolectric grease and go over all connections from battery to pump and quick connects for the lights.

  5. yamaguy

    yamaguy Senior Member
    Messages: 556

    Oh pump, I thought your hot dogs were broken.
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Pm'd back and forth a few times with Ned and it turned out that his motor was shot on the pump...