1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow worked, now won't.

Discussion in 'Truck & Equipment Repair' started by haybaler, Nov 19, 2007.

  1. haybaler

    haybaler Member
    Messages: 38

    I hooked up my plow for the first time this season. worked fine the first time I lifted and angled it. then I drove over to where I wanted to work on it and nothing worked. the pump is running but won't move any direction(except down.0. I changed the fluid and it didn't help. does anyone know how to clean out the screen inside the pump??
  2. sechracer

    sechracer Senior Member
    Messages: 478

    Drain the fluid, pull the pump motor and the screen is on the internal pump......
  3. poncho62

    poncho62 Senior Member
    Messages: 431

    Make of plow?

    Did you use the proper fluid?
  4. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 7,920

    Take a look at the plug.
    Is it clean and making contact.
    some times the plug is loose or not in all of the way.
    The motor may still spin but the plug is loose, dirty, corroded or damaged.
    Last edited: Nov 19, 2007

    KINNCO Senior Member
    Messages: 256

    If it's not making any noise check the power and or the plug connection
  6. haybaler

    haybaler Member
    Messages: 38

    yes the pump is running. it's a fisher and yes I used the proper oil. I'll try the screen tomorrow.
  7. haybaler

    haybaler Member
    Messages: 38

    it was the screen. it was all gummed up. I cleaned it with carb cleaner and now it worked great.