1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow wont work need help?

Discussion in 'Fisher Engineering Discussion' started by stangy2004, Sep 13, 2012.

  1. stangy2004

    stangy2004 Junior Member
    from MA
    Messages: 2

    So this is my first plow. So i dont know much. I had ford install a brand new truck side today. I bought a descent used plow side this summer. So i hook it all up today just clicking. So i use jumper cables from battery direct to motor and it moves with out using the joystick. So now i was gona jump the relay solenoid thinkin maybe its defective but before i was gona do it i tried the joystick and it moved for 3 seconda and stopped and then just clicking again but the clicking is coming from the motor. I cleaned the terminals no luck. What do you guys think? Are you suppose to hear the motor running all the time because i don't hear anything?
     
    Last edited: Sep 13, 2012
  2. nealybird

    nealybird Senior Member
    Messages: 715

    the motor it only supposed to run when you are doing a raise or angle function. when you jump straight from the battery to the motor, the motor should spin but the blade shouldn't move unless you hit a direction on the control.
    since it sounds like an intermittent problem you might try wiggling the plugs at the grill to see if there is something not making good contact there. but since you just had all the truck side installed new, I would take it back there with the plow attached and have them check it out. It could be something they did on the truck side, and if it's a problem with the plow they can tell you what it is and you can decide if you want them to fix it or not.
     
  3. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    Where in ma are you? Ive never had trouble with new parts yet from fisher. Maybe they have something hooked up wrong.
     
  4. NHresident

    NHresident Senior Member
    Messages: 285

    if it moved when u jumped it its not the motor and the motor terminals r REAL clean id say bad plow side battery cable since the trk sides new
     
  5. stangy2004

    stangy2004 Junior Member
    from MA
    Messages: 2

    Well i got lucky i had to bring the truck back today so they could bleed the fuel lines again.Unreal cant even change fuel filters right. So the guy said hed put a new plow on it to see if its the truck side,well it was. A faulty joystick he says it rarely happens. So i got home today and hooked it up works perfect. I got the plow earlier this summer for 1500 SCORE 2 years old and ford charger me 1750 installed truckside. So for 3250 i guess i needed to deal with some issue. Thanks for the input guys and i'm gona enjoy being a new member here.
     
  6. nealybird

    nealybird Senior Member
    Messages: 715

    yes, sounds like you got a good deal. glad everything worked out well.