1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow wont work at all help

Discussion in 'Fisher Engineering Discussion' started by joney5079, Dec 10, 2010.

  1. joney5079

    joney5079 Junior Member
    Messages: 14

    Hey everone I bought a fisher mm2 yesterday. I put it on the truck today got it all hooked up and nothing. The lights dont switch to the plow or anything the truck likhts do still work just fine. When I turn the lights headlights on I do hear a click from the ISO box almost like a relay. But nothing is working. I callled a fisher dealer and he told me that he has onily seen one ISO box go bad in 8 years. Also the power light on the controler isent liting up. yes i did check the 2 fueses they are both good. Any idea what my problem is thanks jon
    This is the 3 conector seperate pump from lift cyl model 7' 6'' blade
  2. joney5079

    joney5079 Junior Member
    Messages: 14

    any ideas at all
  3. scooper87

    scooper87 Member
    Messages: 54

    May be a little time consuming but I would take a test light and basically start at the battery where you know you have power and start checking at each point of connection after that. That way you can check all the switches and relays to see if you have power. Could be something as simple as a bad connection of even a broken wire. Should be able to isolate the problem and fix it.
  4. buddymanzpop

    buddymanzpop Senior Member
    Messages: 597

    Also, re check all your connections, and test the main ground at the battery and the smaller ground to the control harness of that power cable, do like scooper says and get the test light out. Check out your grounds on the plowside also.
  5. scooper87

    scooper87 Member
    Messages: 54

    Something they always told us in trade school:
  6. Make EXTRA sure that the RED wire on the control harness that comes into the cab has keyed power. The controller will not light up unless there is power to that wire.
  7. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    After you check that red wire Motorman described, double check that they tightened the connections at the solenoid, as well as the battery.

    Is this something they installed, or did you wire the truck yourself?
  8. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,214

    You could be having the same problem I did where I was hearing a click and the joystick won't light up.As the other guys said above check the red wire to the ignition.My problem I had was the 10 pin harness for the plow to the isolation module was shorted out and nothing would work,lights nothing.I tried it on two other plows and nothing.I finally replaced the harness from the truck light side to the isolation module and have had no problems.
  9. joney5079

    joney5079 Junior Member
    Messages: 14

    I got her working it was a bad connection from the truck to the plow on the light harness iI Guss their are 2 grounds that have to be connected for anything to work so i cut the old (original) fisher 11 pin connector and the 3 pin pump connector and ran them all through (2) 7 pin trailer connectors and everything works Good lights and pump now all I need is some snow lol
  10. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    You what? :eek:

    I think you took a relatively easy issue and turned it on it's head. :rolleyes: