1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow won't raise

Discussion in 'Truck & Equipment Repair' started by mattia, Dec 10, 2008.

  1. mattia

    mattia Junior Member
    from iowa
    Messages: 4

    I have an insta act fisher plow that won't come up at all. I here the motor running, but it comes up about a half of inch. It looks like a have a little moisture on connections.

    I used this plow the night before and no problems. I accually moved the plow worked good, I disconnected and hooked right back up cause I forgot to do something, then it would not work.

    So I will dry and clean all connections, lube up and then try before I go on to other stuff. But not sure where to go. It does not sound like a solenode., or a motor.

    Thanks for your time.

    Matt
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    pump sound normal or is it high pitch whine?
     
  3. rbergevine

    rbergevine Member
    Messages: 62

    last time you change fluids? Maybe moisture in system freezing/clogging? Check filter for clog
     
  4. mattia

    mattia Junior Member
    from iowa
    Messages: 4

    Pump sounds normal, No lead. What if it was making a whine high pitched sound?

    Fluids should be good, but will check again. filter screen Not sure how to check but will look in to it.

    Thanks for looking.

    Matt
     
  5. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    high pitch whine indicates freezing. also plugged filter. it it sounds different than normal check those.
     
  6. mattia

    mattia Junior Member
    from iowa
    Messages: 4

    Cool thanks no lead and all that helped. I think it's low on fluid. Why I don't know, cause I cycled several times. Fluid does not just go away unless there is a leak. I may had a huge air bubble or something. I am just shocked it's low to that point.

    I will hook everything back up tomorrow and see.

    Matt