1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow wont raise or angle

Discussion in 'Arctic Sectional Sno-Pusher' started by porky19, Nov 19, 2007.

  1. porky19

    porky19 Junior Member
    Messages: 2

    Cant get my blade to raise or angle. Motor runs,fluid is full and the snow is falling as I type sorry I cant be more specific but I need help or I will burn the truck and plow and roast some marshmellows.
     
  2. cooltech

    cooltech Junior Member
    from ontario
    Messages: 5

    try checking the wiring, making sure everything is grounded and you have power,solenoid as well, that happened to me a few years back..
    good luck..
     
  3. porky19

    porky19 Junior Member
    Messages: 2

    Thank you thats what it was a broken ground. Good thing cause I'm out of marshmellows lol. Again thanx for the help.
     
  4. DAFFMOBILEWASH

    DAFFMOBILEWASH PlowSite.com Addict
    Messages: 1,596

    For anyone doing a search; Check the wires near the pump connection. Front of the truck looking for a broken black one. Can tell you how long it took me to find.:D
     
  5. cet

    cet PlowSite Fanatic
    Messages: 7,202

    The brown one might also be the broken one. They brake when you are hooking and unhooking the 4 pin connector. We open up the wiring harness under the hood and cut the black and brown leads and send them straight to the solenoid.
     
  6. real snowman

    real snowman Junior Member
    Messages: 12

    cet

    My pump has a cram or white wire coming from the center of the res. Do just hook up brown to top of solonoid and black to side of batt power and disregard the other.