1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow wont raise or angle

Discussion in 'Fisher Engineering Discussion' started by PlowMan03, Oct 13, 2010.

  1. PlowMan03

    PlowMan03 Senior Member
    from Maine
    Messages: 472

    I hooked up the plow to move it so I could paint it. Got the connections hooked up hit the power button on the fish stick hit up motor just clicks same when trying to angle. What could be the issue? Its a Minute Mount One with the 2 plugs at the grill.
     
  2. PlowMan03

    PlowMan03 Senior Member
    from Maine
    Messages: 472

    I was wrong when I said the motor clicks, come to find out its the silinoid thats clicks could that possibly be gone?
     
  3. mycirus

    mycirus Senior Member
    from Mass
    Messages: 589

    Check your connections, especially your ground and make sure they are clean and tight.
     
  4. plowguy43

    plowguy43 PlowSite Fanatic
    Messages: 5,269

    Jump the solenoid with a screw driver. If you plow moves than its gone. Check all of your grounds too.
     
  5. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    Solenoid is probably bad, mine did the same thing when I pulled it out of storage; new solenoid and its good to go.
     
  6. PlowMan03

    PlowMan03 Senior Member
    from Maine
    Messages: 472

    I think I found the problem. I recently had to have a new motor put in my truck, the shop that did it put a new battery in it and they forgot to hook the ground wire back up to the battery. I hope thats the case.
     
  7. plowguy43

    plowguy43 PlowSite Fanatic
    Messages: 5,269

    That would definitely cause an issue lol. Let us know! And post some pictures!!!
     
  8. PlowMan03

    PlowMan03 Senior Member
    from Maine
    Messages: 472

    I was right about the battery thankfully lol. Plowguy I have posted some pics of my truck in the pics forum under the thread Post pics of your trucks here at the top of the page and I think they are on page 76 lol