1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow wont go down HELP

Discussion in 'Blizzard Plows Discussion' started by ricothunder, Dec 24, 2007.

  1. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    i was plowing today and all of a suden the plow wouldnt go down anymore. so i went out and checked the hoes every thing looked ok .. so i tryed the plow reliece switch and it went down .... but would not relice off the truck so now iam stuck ...please help got to get plow working to finsh jobs
     
  2. GFX

    GFX Member
    Messages: 49

    Check the coils. I'll bet your problem is there. They go bad. Don't ask how I know. S-5 coil is always the one that goes bad on me.
     
  3. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    will it work some times than not....cus this happend last week and i didnt think anything of it cus it started to work after a bit so i thought it was just frose up but i guess not cus it did it again today
     
  4. GFX

    GFX Member
    Messages: 49

    Yup. That's how mine went. Sometimes worked and other times it didn't. Won't be long till it won't work at all.
     
  5. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    do you mean the s5 solenoid or am i looking at the wrong part
     
  6. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    yes coil=solenoid in his description
     
  7. magnatrac

    magnatrac PlowSite.com Addict
    Messages: 1,055

    In the past I have had the same problem. Once you start having it act up just replace the coil. You can clean it to get you by for now. I replaced mine and was good for the season ,but the following season I had corrosion make it into the valve itself. Replaced that and finally got the supposed weather proof coil and was good for two more years. The plow spends alot of time in the float positon and when it is powered it will corroed faster. Just like when you tow a trailer with you parking lights on that pin on your plug will corroed faster than the others. I don't know if it helps but lightly greased all of my coils after I had this problem the second time. Just my $.02 ,Good Luck!!!
     
  8. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    thanks for your help i will go to the shop tomorow to get the part since its christmass today oh ya merrychristmas to all
     
  9. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    need more help

    ok guys i relay need your help now!!!!!!!!!! ok i check the coil/solinods both the s5 and s8 are pulling i took them off and than put a screw driver in it and pushed the hook upand disconect switch and they both have power going to them..... than i replace the valves if i am corect witch is what the coil is screwed on too and still the plow wont drop or disconect....i hear the pump working but wont drop... it never works from in the truck but will go up and some times down by the plow switch ................what else could it be
     
  10. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    will go down but not disconect
     
  11. 10elawncare

    10elawncare Senior Member
    Messages: 291

    heres a bump for ya...
     
  12. GFX

    GFX Member
    Messages: 49

    I still think it is a coil. Why didn't you replace the coil? The can be bad and still work at times. Mine started acting up again last night. Luckily, I got everything done without using float. Had about 10 times the plow would not drop last night.

    Another thing would be look in the controller box to make sure that the diode hasn't melted off.
     
  13. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    diode ?? and i didnt change it cus i was told if it is pulling its not the prob,,, see the coil was puilling but the plow didnt do any t hing that is why i am in ahhh.. all concetions are good
     
  14. GFX

    GFX Member
    Messages: 49

    Just because the coil "pulled" when you checked doesn't mean that it is not bad. You said in your first post that it happens every once in awhile. Maybe when you checked it, it was one of the times it decided to work.

    Here's a picture of my first coil I went through. I plowed with this coil for quite awhile until I was having so many issues that it simply didn't work anymore. Once this thing exploded enough to touch the flow control it was all done and would not work period. Until that point I was able to wait for a bit and then it would work again so I could finish plowing. All the "connections" were fine so just because you found your connections to be fine doesn't mean much.

    Do you have a dealer nearby? It sounds to me like you should just maybe take it there and have them look at it. IMO, I'll bet you'll walk out with a new coil and labor to install it.

    The S-5 coil is known for going bad on these. The problems which you speak of are symptoms of a bad S-5.

    IM004210 (Custom).JPG
     
  15. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    dealer is 30 min away no big deal to get parts but when i asked for them to work on the plow they said they need my truck and wont set up a time so i can stay and wait so ...since i need the truck i have to do this my self.....now for the coil what did u do to replace it just cut the wires off and splice the new ones on?????
     
  16. magnatrac

    magnatrac PlowSite.com Addict
    Messages: 1,055

    That's how I have always done it. I use a crimp connector and then shrink tube to seal it all up. It's a quick easy fix I carry everything to do it in the field. From what I have read that sounds like your problem. Good Luck !!!
     
  17. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Just try the S5 coil, if that isn't it, you have a spare. But I'll join with those voting change the coil.
     
  18. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    fixed it

    ok i realy didnt want to go get a coil cus i relay didnt think it was it because it was pulling strong so to make a long story short i took the hoses off the ram for up and down and found out that one hose was pusing fluid for up and down so ... i check each coil again all good so than i started checking the vales firs one s7 dint want to click so i changed it with a new spair i had and bingo bango the plow worked .........thanks for all your help hopefull i can get through the last 2 months with no problems
     
  19. GFX

    GFX Member
    Messages: 49

    Good to hear you got it fixed. Didn't know you had an older model plow till your last post. The newer plows don't have the S-7 anymore.
     
  20. ricothunder

    ricothunder Member
    from ontario
    Messages: 75

    what year u think

    i didnt think the plow was that old well i think 5 years old what do u think