1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow wont angle either way

Discussion in 'Fisher Engineering Discussion' started by vortec5.7, Jun 24, 2010.

  1. vortec5.7

    vortec5.7 Member
    Messages: 58

    i have a fisher minutemount 1 2 plug i went to move it and the plow wont go either way, so i took the motor off pulled the pump cleaned the pump and the resovior put on a new filter and changed the coil that controls left and right. i hear the motor but it still wont angle. the lift cylinder is up so i cant tell if it is the pump. please give your input on it because i dont no what else to do is there a bleed screw somewhere ?
     
  2. vortec5.7

    vortec5.7 Member
    Messages: 58

    bump removed the s3 cleaned it and re installed still nothing...
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Check the S2 coil for magnetism. If it doesn't have it then start looking for an issue on the light green wire from the coil back through the grill connector (paying EXTRA special attention there) and back through to the controller. You can also hot wire the S2 to check it directly.

    If there's mag but it still won't angle then pull the S2 valve and check it over.


    You should also attempt to lower and then raise the lift ram to be sure that's all working correctly.
     
  4. vortec5.7

    vortec5.7 Member
    Messages: 58

    thanks im gonna try that tomorow
     
  5. vortec5.7

    vortec5.7 Member
    Messages: 58

    hey guys i checked all my grounds cleaned grill conectors went to the sylinoid cleaned thoes connectors the s2 is constantly magnetic i dont no if it is supose to be like that all coils are magnetic when tested if any one can tell me what to try next would be greatly apprecated i had just bought this a year ago and the motor looks like new i dont no if it is turning the pump fast enough?
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    No the S2 shouldn't be magnetized constantly, only when the angle left or right functions are pressed.

    Definitely need to check for a wiring or controller issue.
     
  7. vortec5.7

    vortec5.7 Member
    Messages: 58

    thanks b&b when it comes to electric pumps im dumb so your help is great
     
  8. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You can find, download and print off all of the misc diagrams for your setup from Fishers website if you're not aware. Makes it much easier to troubleshoot when you have it right there in front of you.
     
  9. vortec5.7

    vortec5.7 Member
    Messages: 58

    i looked at the website that repair manual is great also when i said s2 coil was constantly mag i ment s1 so it looks like i have some wiring to do on the next rainy day
     
  10. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    I suspected you had the coils mixed up. The S1 WILL show mag any time the controller is on and in the float position so that would be correct. You should also be able to force the lift ram down at that time as well. Then check to see if it will lift.
     
  11. vortec5.7

    vortec5.7 Member
    Messages: 58

    update plow will now only angle right and do nothing else i am going to try replacing the cartrages tonight to se if that will help if not im at a dead end
     
  12. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Before just replacing parts; connect a fused 12V jumper wire directly to the S2 coil (light green wire) and then press the left angle function. Does it then angle left?
     
  13. vortec5.7

    vortec5.7 Member
    Messages: 58

    i will try that tomorow thanks
     
  14. plowguy43

    plowguy43 PlowSite Fanatic
    Messages: 5,269

    I think you have a controller issue. My plow would lock up as well with my old fishstik- did a bunch of research/reading (B&B!!) and tried a different controller and the plow worked fine. Purchased a new circuit board for my Fishstik and it worked flawless the rest of the winter.
     
  15. vortec5.7

    vortec5.7 Member
    Messages: 58

    yeah im gonna try the spair controler i hope thats all i need to do
     
  16. plowguy43

    plowguy43 PlowSite Fanatic
    Messages: 5,269

    You figure it out yet?
     
  17. vortec5.7

    vortec5.7 Member
    Messages: 58

    i havent figured it out yet i cleaned the grille connectors im gonna try re cleaning the cartridges tomorrow all i can think of now is them or something else in the valve body
     
  18. vortec5.7

    vortec5.7 Member
    Messages: 58

    im almost ready to take it off and pay some one to fix it because im stumped
     
  19. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Other than cleaning the valves and grill pins you haven't stated what else you've done or not done so it tough to help with the next step to diagnosing it. Did you try a different controller? Did you jump the S2 and if so what did it do? Need details.
     
  20. vortec5.7

    vortec5.7 Member
    Messages: 58

    i tried a different controller and it still did the same thing (motor ran) i also jumped the s2 cartridge and the motor ran no movement to the plow at all.