1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow will not angle.

Discussion in 'Truck & Equipment Repair' started by macawpat, Nov 19, 2008.

  1. macawpat

    macawpat Member
    Messages: 54

    When I first purchased my used western plow mark III cable operated plow everything worked fine up down and side to side. The next day it would only move up and down. I took it in for service because I was told it had sat for a while and the service person found quite a bit of water in it. after flushing it out several times the water was gone but still will not angle either direction.The Western tech told me that when tyring to move it left or right both hoses pressurize and will not let it go in either direction. He seems baffled can someone out there give me an idea what advice to give to my WESTERN AUTHORIZED TECH so he can get my plow back on the road?? Thanks for any help, Pat
  2. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    A factory tech, has he ever seen a cable operated system?
    Sounds like one valve is not opening or a quick connect is not fully engaged.
    Might try carefully taking the hose off the extended ram at the cylinder. Wrap a rag around the fitting so it does not spray fluid everywhere. This will relieve the pressure. Then make sure both quick connects on the ram hoses are fully engaged. Both connectors may need replaced. They can get worn out / dirty and not work right after a while.
  3. macawpat

    macawpat Member
    Messages: 54

    Thanks for the info I will relay the message to him. He has had my truck for going on two weeks now but is only in the shop for 2-3 days a week and I want my toy back. Thanks again :)
  4. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    Gotta hate when u want to play with your toy and it's in the repair shop!
  5. Dieselpower25

    Dieselpower25 Junior Member
    from PA
    Messages: 14

    I had this problem on an old cable western, turned out that the linkage at the pump was so worn it wouldnt open the valves
  6. lazarus

    lazarus Junior Member
    Messages: 17

    hopefully i'm not hijacking the thread but i have similar problem. i can go left and right. can also go down, but when i try to go up it only takes what little slack in the chain is there and that's it. it dont have enough to lift the plow. i have a Mark IIIa western cable. i also took off those little covers and manually tried by moving that arm but still same results. any ideas would be appreciated.
    i'm not very literate when it comes to plows as i am just getting started last year so all answers are hopefully so a dummy could understand:)