1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow stuck up

Discussion in 'SnowDogg Snow Plows' started by Sydenstricker Landscaping, Feb 8, 2011.

  1. Sydenstricker Landscaping

    Sydenstricker Landscaping PlowSite Veteran
    Messages: 3,882

    My ex80 dogg which is almost 2 years old is stuck all the way up. Checked the fluid and it is good. It goes left and right, and when up is pushed the motor does work. I took a jump pack to give power to the front coil and got it to drop. I'm guessing either a valve or coil issue. Any help will be good since my dealer won't. That will be a different thread
     
  2. slone

    slone Senior Member
    Messages: 183

    not very good pr. i bought my snow dogg with toms recomendation. great plowing machine but i had the same problem last week except my plow would not go up. hit the up button plow would go left, tom came to help me chain it up finally got it chained after pulling my back out. the only other problem i am having is with the controller. the light always wants to turn red. i can't find anything in the manuel to address this. some help would be great. and ya i bought mind from the same dealer as tom.
     
  3. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    you guys didnt go 2 mr muff diver did you
     
  4. Sydenstricker Landscaping

    Sydenstricker Landscaping PlowSite Veteran
    Messages: 3,882

    No lol. He actually helped me get the plow down though. At least they tried.
     
  5. djagusch

    djagusch 2000 Club Member
    from mn
    Messages: 2,071

    Sounds like it has the lift cyl issues. Gunk clogging the valve screen. To get it down loosen the hose but stay clear as it will drop. Now take out the valve for going down. Most likely you will find the screen clogged with black gunk. Clean it and it will last a couple times. If this is what you find you'll need a lift cyl, system flush and maybe a valve.
     
  6. Sydenstricker Landscaping

    Sydenstricker Landscaping PlowSite Veteran
    Messages: 3,882

    Pulled the valve and it is clean. Checked the magnetism and there is none
     
  7. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    sounds like a coil 2 me
     
  8. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Check the blue wire on the SA coil for voltage with the plow in float Tom. If there's no power there then it's probably an issue in the bumper connector. Keep your toes clear when doing so.
     
  9. Sydenstricker Landscaping

    Sydenstricker Landscaping PlowSite Veteran
    Messages: 3,882

    It was that wire. Was broke inside the plowside harness. All good to go! Thanks
     
  10. BMAN1

    BMAN1 Member
    Messages: 93

    My plow is pretty out going and friendly. I am glad I didnt get one of those rude stuck up ones......
     
  11. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    I usually find it's more a problem with the operator than the plow....at least a snow plow will do what you tell it the majority of the time.
     
  12. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992


    There is a tech bulletin out on that. Contact your dealer or Snowdogg direct and get the adapter plug. They explained it as they don't know why but there is some back feeding going on somewhere in the system, and it feeds though the unused pins on a straight blade. So if you ask they will send you a jumper plug to go between your harness and the controller so the wires aren't there to back feed though. Probably something to do with the quality of the harness's manufacture.
     
  13. slone

    slone Senior Member
    Messages: 183

    thanks. they are getting me the adapter. the red light just drives me nuts
     
  14. mikef54

    mikef54 Junior Member
    from Buffalo
    Messages: 15

    Recently having problems lowering blade. Was doing some plowing blade stopped lowering. Was driving and had blade in float and it dropped. Went back made a few passes the it stopped lowering again. Any advice welcomed.
     
  15. npi9181

    npi9181 Member
    Messages: 32

    mike bring it monday I'll get you fixed up and working

    Ken @ Niagara Performance
     
  16. mikef54

    mikef54 Junior Member
    from Buffalo
    Messages: 15

    You guys are the best, went back out put in float wiggled the harness and plow dropped. Going to pull the the plow side harness and checked. Hope it's that. Have to clean up two lots before AM. If not will stop in.
     
  17. mikef54

    mikef54 Junior Member
    from Buffalo
    Messages: 15

    Thanks Ken and B&B blue wire pinched up and running again.