1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow stuck in up position

Discussion in 'Truck & Equipment Repair' started by kdw3k, Dec 2, 2007.

  1. kdw3k

    kdw3k Junior Member
    Messages: 2

    I went to use my plow today and once it was raised that was all it would do. The float light on the key pad came on but I can't find what that means anywhere in the owners manual. It is a Myers E-60 unit with the touch pad control. Any suggestion would be helpful as this is the first time using a plow.
  2. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    If it will not lower the problem is in the A-Coil. and/or the A-valve.

    1. Make sure its plug in.

    The A coil and valve, will be one closest to the front of the pump near the lift ram. its the one with the black wire.

    Once you check to make sure its plug in and getting power toit.

    While its in float mode is on, tap the top of the A coil with a hammer, if its stuck close, some times tapping it will open it, when doing this WATCH YOUR FEET!!!!

    It it dose go done or it has power and is not working, replace the coil and valve.
  3. cog-1

    cog-1 Senior Member
    Messages: 117

    We've had problems with ours when it is real cold out, freezes up. We just bring it inside for awhile to thaw it out...not saying it couldn't be valve or something...
  4. kcplowmata

    kcplowmata Senior Member
    from kc
    Messages: 174

    get your wife from under it!!!!!!!!!!!!!!!!!!!!!!!!
  5. kdw3k

    kdw3k Junior Member
    Messages: 2

    Thank you for your imput. I double checked the connections, warmed the unit up,gave it a few love taps, and she works like a charm.
  6. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    Ok sounds like the A needes replaced !!!