1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow side lights work 50% of the time ??help

Discussion in 'Fisher Engineering Discussion' started by Maleko, Nov 26, 2014.

  1. Maleko

    Maleko Senior Member
    from Ct
    Messages: 776

    8' XBlade. 3 port brain , 3 plug to plow .
    Lights worked fine when I hooked up.
    Drove home no prob lights stayed on.
    Got home turned off truck. Went to move truck. No lights at all.
    Checked all fuses unplugged every connection lights then worked.
    This morning head out. Lights work.
    Stop at Home Depot. Turn on truck. No lights. Unplug harness. No lights
    Turn truck off. WAMMM lights back on....

    Any clue to what's going on????
  2. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,257

    check and see. If were the headlights are mounted if they are grounded i had 1 that got corroded and lost its ground its common
  3. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,214

    If you wiggle the connections from the truck to the plow do they flicker?Could have a bad harness plow or truck side getting ready to go
  4. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    Sounds like a bad harness, or loose pin in the eleven pin. Could also be a failing relay in the iso module, but not as likely.

    Also, the lights are not grounded through their mounting point as someone suggested.
  5. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    Check where the plow parking lights are hard spliced into the truck harness. It's that circuit which switches the iso module relays on when you plug the plow in.
  6. Maleko

    Maleko Senior Member
    from Ct
    Messages: 776

    Thanks. I'll check some more today.
  7. Too Stroked

    Too Stroked Senior Member
    Messages: 548

    That's the number one thing we do in this case. Usually you'll find a bad harness - right at the strain relief of course.
  8. Maleko

    Maleko Senior Member
    from Ct
    Messages: 776

    I wiggled everything.
    Unplugged everything
    Checked fuses.
    Pins are solid. None loose. No corrosion anywhere.
    What's odd is, I noticed when the time the lights won't come on I'll start to drive anyway cause my truck headlights are on. In about 30 sec all of a sudden it switches to the plow lights BAMMM then they stay lit.

    I'm stumped.
  9. Check the connections at the isolation module or "brain" as you call it.
  10. Maleko

    Maleko Senior Member
    from Ct
    Messages: 776

    Did that all good
  11. Whiffyspark

    Whiffyspark 2000 Club Member
    from SOMD
    Messages: 2,401

    Automatic headlights on truck?
  12. Maleko

    Maleko Senior Member
    from Ct
    Messages: 776

    Yes. The switch has an auto setting and I canna also turn them on and off manually.
    They worked fine last year though.