1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow shorted out

Discussion in 'Fisher Engineering Discussion' started by pats plowing, Mar 18, 2007.

  1. pats plowing

    pats plowing Senior Member
    Messages: 281

    Basically, the plow is draining the battery and is not running from the alternator. I have changed the battery in the truck and it is doing the same thing. The plow was still operational but it was dimming the lights and turning off the radio whenever it was lifting or angling. I believe there is a short but I only checked the fuse off of the module?? under the hood and where the red wire connects into the fuse box. It is a 2 year old 8' xblade on a 04 350. Could it be the truck alternator? I can put a different plow on it to test but its a pain because that plow has to be jacked up to fit on the truck.
     
  2. MOXIE

    MOXIE Member
    Messages: 38

    It could be the alternator, but it is most likely a connection to the Fisher motor
    solenoid or battery connection. Ford battery terminals are not my favorite. The
    aux power taps could be your problem. The fuses you checked are only for
    control to protect the E-Force box.
    Your radio shuts off because it has "low voltage protection" built in.
    Duel batterys and clean connections [dialectric grease] should solve your
    problem.
    MOXIE
     
  3. grassmanvt

    grassmanvt Senior Member
    from Vermont
    Messages: 153

    A couple chevys I've had have done that, couple times a new battery fixed it, once it was the alternator. Have a good shop check it.
     
  4. harley hauler

    harley hauler Senior Member
    Messages: 214

    My truck did the same thing, lights would dim, dash lit up like a christmas tree, radio went out, well changed the obvious the battery still did the same thing, went to my mechanic tested the alt and it was on it's way out so after new bat and alt. shes fine