1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow raises real real slow

Discussion in 'Blizzard Plows Discussion' started by tubbykid, Jan 28, 2010.

  1. tubbykid

    tubbykid Junior Member
    Messages: 13

    i cant figure this thing out maybe some one else has an idea....on i of my 810 s with both wings run out the plow raise real slow the fluid is full and with the plow slid in it works fine .........any ideas
     
  2. damian

    damian Senior Member
    Messages: 330

    usually its the pump,suck the fluid out of the reservoir,if it is black at the bottom it is a dead giveaway.the motor grounds at the contact point where it attaches to the pump block,this becomes corroded and the motor finds ground at the pump gears and housing arcing them away.remove the reservoir and pump check the gear shaft where goes through the housing,it will be egged. the wings move fine because they require less pressure.you will find the motor usually pulls around 160amps to lift,with a worn pump it wont pull so much.
     
  3. Mark Witcher

    Mark Witcher Senior Member
    Messages: 604

    Well if it only lifts slow with the wings extended, it sounds like its sucking air. Pickup tubes maybe fell off the pump. This would be the only explanation. Pull the tank and take a look.
     
  4. damian

    damian Senior Member
    Messages: 330

    disregard my advice tubby,i misread your statement,i missed yhe fact that it only lifts slow with wings out but works fine wings in,mark witcher is right,it probably turned the suction screen up or something like that.sorry about that.