1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow Problems

Discussion in 'Truck & Equipment Repair' started by roel, Mar 15, 2006.

  1. roel

    roel Junior Member
    Messages: 1

    bought a 01 gmc sierra with western plow 3 years ago never changed the western plow oil wondering if thats the reason the plow wont work at all.It does nothing but a wierd noise.id appreciate some advice even though by the time i get some feedback ill probably have tooken care of the problem.i went to the western website got angry cause i went to the troubleshooting and this is ridiculous they had all these options but not my problem. how could they be so unprofessional to not list this"PLOW DOESNT RAISE TURN LEfT OR TURN RIGHT" ,i mean isnt that one of the most common problems?they had every other problem with the plow except that one.A problem with my situation is that i bought mine used therefore idid not receive any manual with it so i am not familiar with any internal part of the motor or maintenance besides the changing of oil . thanx for your time.::
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,990

    Could be a cooked Hydraulic pump or motor. How many Amps is the motor drawing? Is the pump producing pressure?
  3. mmwb

    mmwb Senior Member
    from wyoming
    Messages: 114

    On the Western site there are manuals including installation, service, etc.... The service manual I down loaded for my old conventional had a trouble shooting section. Angling/raising problems are covered. What model of plow are you dealing with? Get the service manual for your model. It doesn't take too long to download. I'd recommend changing the oil out seasonally.
  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    the answer is in the mechanics troubleshooting guide, you just need to read a little deeper. Start with checking the fluid level and and your battery cable connections then go to the motor test and then motor solenoid test and work from there.

    The more info you can give, like does the light on the controller go off when
    trying to run it, does the solenoid click, wheres the weird noise coming from makes it easier to tell you where to start.

    And is this a uni mount or ultra.