1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow problem

Discussion in 'Truck & Equipment Repair' started by rmartini27, Feb 1, 2009.

  1. rmartini27

    rmartini27 Senior Member
    Messages: 118

    hey does anyone know how to figure out if the plow motor is faulty or if its the plow pump? i have a 94 gmc 2500hd with a elec/hydro fisher plow probably the same year. the motor sounds like its running but the plow does nothing. i change the fluid once a year. i don't feel like buying both parts. i removed the pump and it seems fine. i'd be great full for any advice.
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    does the motor spin fast? if so, is the pump making pressure. lift the plow up with a floor jack. will it angle? if yes lower plow. angle now? a pressure gauge is your best bet to test the pump.
     
  3. rmartini27

    rmartini27 Senior Member
    Messages: 118

    yes the motor is spinning, the pump is providing pressure, i took off the manifold and discovered a broken spring for one of the valves. i am not sure if that is the problem but i don't think it helps
     
  4. rmartini27

    rmartini27 Senior Member
    Messages: 118

    i did blow out both hoses on a rock a couple storms ago other maybe that had something to do with it?
     
  5. wildbro 1

    wildbro 1 Junior Member
    Messages: 15

    did you change the couplers by chance when you changed hoses when you changed hoses
     
  6. rmartini27

    rmartini27 Senior Member
    Messages: 118

    no does that damage the couplings?
     
  7. rmartini27

    rmartini27 Senior Member
    Messages: 118

    the valve spring is a popplet check valve. could that present the problem i'm having
     
  8. wildbro 1

    wildbro 1 Junior Member
    Messages: 15

    no but some couplers are poorly built and ive bought brand new ones and they didnt work properly
     
  9. wildbro 1

    wildbro 1 Junior Member
    Messages: 15

    so the motor runs but nothing happens
     
  10. rmartini27

    rmartini27 Senior Member
    Messages: 118

    yeah the motor runs the pump seems to work also. the plow is frozen in place no left or right though it tries i slammed the plow into a bank to straighten it out but it wouldn't move
     
  11. rmartini27

    rmartini27 Senior Member
    Messages: 118

    the plow worked after the hoses were replaced
     
  12. rmartini27

    rmartini27 Senior Member
    Messages: 118

    bought the part online but i needed the truck for a storm tonite so i went to the local shop to see if he had it. of course he didn't so he told me to try a spring from a pen. which as crazy as it sounds worked. so if your ever in a pinch