1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow parking lights

Discussion in 'Western Plows Discussion' started by M&M Services, Dec 9, 2009.

  1. M&M Services

    M&M Services Senior Member
    from midwest
    Messages: 485

    Well guys, the parking lights on my plow went out. I pulled the drivers side truck headlight off, and found a bad connection to the factory harness. My buddy jiggled the wires and the plow side parking lights came on. We turned off the lights, cut the connector and redid the connection and now nothing on the plow side. Turn signals work etc.. any ideas? The plow has the nighthawks, not that it matters...

    Thank you,
    Mike
     
  2. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    What works and what doesn't? The Nighthawks are like the Intensifires, correct? If you unplug the plow, do the truck lights work? There are two fuses near the lighting Iso module for the headlights.
     
  3. M&M Services

    M&M Services Senior Member
    from midwest
    Messages: 485

    With the plow off all the truck lights work, turn signals, parking lights, headlights.
    With the plow on, the headlights, turn signals and hazards work. The parking lights do not
    Can the ISO module go bad and cause this issue?

    Thank you,
    Mike
     
  4. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Parking lights DO go through the Iso module, so that's a possibility. Fisher's schematics don't show the details of the actual Iso module, but I would be surprised if there is actually a switch for the parking lights. I doubt your problem is there.

    Both park lights come through one pin on the grill connector. Looks like it's pin 10 on Fisher's schematics. I think they are numbered, you could check for voltage at the grill. Confirm it goes off and on with the parking light switch.

    If you don't have voltage at the plug you may need to pull the grill/truck parking lights and find the the wire that is spliced into your truck lights. That could be where your problem is.

    If you do have voltage at the grill plug, there is a splice in the harness on the plow side.

    Pages 32-34 give you the wiring schematics.
     
    Last edited: Dec 9, 2009
  5. M&M Services

    M&M Services Senior Member
    from midwest
    Messages: 485

    Thank you for the info.. After some trouble shooting, I think it is the 11 pin harness on the truck side. I tried to jump directly from the brown wire (parking lights) to battery power... No lights, but when I jumped from battery power to the plow side, they worked..
    Anyone have Western harness # 26357?

    Thank you,
    Mike
     
  6. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    I might have it. Need to check the numbers.
     
  7. M&M Services

    M&M Services Senior Member
    from midwest
    Messages: 485

    Sounds good. Let me know...