1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow not raising with sno-commander setup????

Discussion in 'Ram Trucks' started by Kentuckydiesel, Dec 29, 2005.

  1. Kentuckydiesel

    Kentuckydiesel Senior Member
    Messages: 151

    I hooked my stuff up on my '79 dodge and all was well. The plow raised just as it should, angled perfectly, dropped a little slow, but I was very happy with how everything worked. I raised and lowered it a few times then drove about 10 miles where I dropped the plow again. After that, it wouldn't raise more than a couple inches. It was acting like our batwing bush hog when one of the wing cylinders starts leaking past and fluid builds up on the wrong side of the cylinder. Could this be the case on this cylinder? When I pull the lift lever, all the hyd. lines jump and you can hear the engine bog down, but no lift.
    I was very happy with this setup until it quit lifting. It was every bit as fast, if not faster than the electric/hydraulic western plow on my grandparent's f250 and it functioned much better.

    Thanks, Phillip
     
  2. Kentuckydiesel

    Kentuckydiesel Senior Member
    Messages: 151

    I rebuilt the cylinder today. Meyer dealer wanted $53 for a rebuild kit. I dropped by a small hydraulic shop I know of, they set me up with the seals for $15. :drinkup:

    I rebuilt and painted the cylinder then put it back on the truck It seems to work fine now. -Phillip