1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow Mounted and Almost working on the Avalanche

Discussion in 'Chevy Trucks' started by andym1996, Nov 12, 2008.

  1. andym1996

    andym1996 Junior Member
    Messages: 14

    I replaced the solenoid and the plow itself works :drinkup:.

    Problem - the lights. I think the guy i bought the plow from was on crack. The lights dont work at all. I have not changed any of the relays, and i have the wires all run as they should to get the parking lights on. Any suggestions for the following:

    with just the low beams on Truck OK- driver side parking light on - plow light bar
    with just high beams on Truck OK- driver side parking light on only - plow light bar
    right turn signal - OK, both beams truck side, - plow side nothing, just the driver side parking light.
    left turn signal: the low beam on the plow turns on, and all what ever beam is selected, that beam flashes on the truck lights. Passenger turn signal lights flash too.

    Do i start over, and un-plug all the relays? They are not in the order as the Western Install guide Suggests.

    Any Ideas?

    Overall - pleased with the plow, and how the back drag feature works! Its a very slick deal and appears that it will work really well.


    Andy

    IMG_1466.jpg

    IMG_1468.jpg

    IMG_1469.jpg

    IMG_1471.jpg
     
  2. mcwlandscaping

    mcwlandscaping 2000 Club Member
    Messages: 2,557

    That looks great! I like the look of those 3/4 ton avalanches =] doesn't seem to sag much either on the front end
     
  3. sechracer

    sechracer Senior Member
    Messages: 478

    yes, start over with the light relays and hook them up as directed, if not, they wont work right....
     
  4. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,737

    6.0 or 8.1?
     
  5. William B.

    William B. Senior Member
    from S.E. IA
    Messages: 978

    8.1

    I wanna see pics of the DMax.
     
  6. RichG53

    RichG53 PlowSite.com Addict
    Messages: 1,135

    That's how that back drag works !!! I could probably fab one for my Hiniker...Looks simple...
     
  7. andym1996

    andym1996 Junior Member
    Messages: 14

    Overall, i am pleased with the result. I just need some danged lights! Ill get my patience out tonight, then get that going. The Blizzard will be on the truck this weekend. i robbed the blizzard's solenoid to make sure the Western Worked. Ill get pictures of the trucks i mount and wire this weekend. (3) of my buddies bought new plows, so i get to wire them this weekend.
    (1) 04 Chev 2500hd Duramax w/ Blizzard 860
    (1) 02 Chev 2500hd Duramax w/ Hiniker "c" plow
    (1) 07 GMC 2500hd Duramax w/ Blizzard 860

    Should be a good picture!
     
  8. sechracer

    sechracer Senior Member
    Messages: 478

    Yes, the relays are the same... Just make sure you get ones for a plow as I am not sure if they are different than the cheap ones you can get at autozone.
     
  9. RichG53

    RichG53 PlowSite.com Addict
    Messages: 1,135

    Hey ANDY; If you can shoot some more pic's so I can see everything...Get a better Idea ... Thanks1111
     
  10. andym1996

    andym1996 Junior Member
    Messages: 14

    Rich - Shoot me an e-mail if you are interested in the photos. I can then send you the larger sized ones so you can actually see what is going on on the thing.

    armichels@gmail.com

    andy
     
  11. andym1996

    andym1996 Junior Member
    Messages: 14

    Since this AM, i have talked to Jerre, he is going to help me get through the headlight wiring later tonight. That sounds like what we are going to do though... start from scratch.