1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow Melt-Down

Discussion in 'Western Plows Discussion' started by procut, Mar 4, 2008.

  1. procut

    procut Senior Member
    Messages: 902

    Ok, here is the story. '95 Chevy w/ Western Uni-Mount.

    I had a relay go bad, and cause the motor to run continuesly. By the time I realized this, the ends of the cables on both the truck side and the plow side had melted.

    I went to the dealer, bought the two new cables and a new relay, came home slapped them on qucik and still nothing. Today, I get into the truck to take it to the Western dealer to have it fixed, and it will not start, despite the fact that both batteries are full charged. All I hear is a clicking sound when the key is turned. I have a hard time beliveing the starter would have gone out, becasue it was replaced about one year ago. I checked, battery connections, and they seem good and tight.

    Is there something I could have done when changing the cables and relay that could have shorted something out ect. that would cause this. Any suggestions would be great!
     
  2. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,574

    ..................
     
  3. procut

    procut Senior Member
    Messages: 902

    ^ What is that supposed to mean?
     
  4. iceyman

    iceyman 2000 Club Member
    Messages: 2,546

    try jumping the starter just to get it to the dealer...
     
  5. procut

    procut Senior Member
    Messages: 902

    Got it figured out, bad ground.
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    That'll do it!