1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow lights

Discussion in 'Truck & Equipment Repair' started by al45target, Jan 24, 2012.

  1. al45target

    al45target Junior Member
    Messages: 11

    06 Silverado, 3/4 ton. Lost the low beam drivers side.. New blub no difference. High beam works. Rang out wires from head light to plug, ok. Where do I start now. Fisher MM-2. Al.
     
  2. allen81

    allen81 Member
    Messages: 97

    Did you ever fix your issue? I have the same issue. But right now I have both lights working on high beams but passenger is bright and driver side is dim.
     
  3. al45target

    al45target Junior Member
    Messages: 11

    No issue still there. Rang out the light blue wire from the plow light, (dim) to the Isolation module. I think that might be the problem.Wire is good all the way. ANYBODY am I on the right track?
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Is it a 3 pin ISO?
     
  5. al45target

    al45target Junior Member
    Messages: 11

    Issue not fixed. Going nuts. Rang out the wire for low beam, all okay. Installed new he4adlight relay no help. Next step I guess is going to the dealer. Al
     
  6. al45target

    al45target Junior Member
    Messages: 11

    Yes it is 3-port module. Put in new headlight relay, no help. The low bean drivers side on truck works. ARE WE GOING TO GET ANY SNOW?
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Did you double ck the plow harness to truck harness?? There's an a and b on the plow plug. Make sure that's the right way
     
  8. al45target

    al45target Junior Member
    Messages: 11

    I found those A and B plugs you are talking from before, behind the left headlight. On both plugs have an A side and a B side. I may not be the sharpest knife in the drawer, but how can you tell if they are right if both have the same markings on each plug? Al
     
  9. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Ok if i remember correctly...the way they work are......if your truck has pos. Or neg switched lights. If your truck has pos. Switched light then on the plow harness side, it will say low beam pos(something like that). And the other pin will say drs. Common. So one side is gnd and ones pos. So you neede to double ck what your truck is,,then make sure there plugged in the right way.....i think it was pin a on the 3port that should have drs pwr.
     
  10. al45target

    al45target Junior Member
    Messages: 11

    Okay, will give that a try. Get back to you after I check. Never had the problem last year or in Oct. storm. You gotta love the wires. Thanks dieselss, Al.
     
  11. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Yep they are great. Also double ck the gnd wire at the plow pump. Thats still what switches your lights,,,truck to plow
     
  12. farmtruckerboy

    farmtruckerboy Member
    from PA
    Messages: 43

    I also have a problem with my snow plow lights on my boss v-plow I move the lights up to shine further away but when I tighten them the go down I have even try putting my hand under the light and then tightened but that still does not work can anyone help me please?
     
  13. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Try the boss fourm farm. Might get better help there
     
  14. farmtruckerboy

    farmtruckerboy Member
    from PA
    Messages: 43

    ok thanks i ask them
     
  15. brettz28

    brettz28 Junior Member
    Messages: 20

    So I see your old reply here, and am wondering if you would mind elaborating?? I have a 2003 Tahoe with a 1 yr old ultramount. I have no low beam lights at all. The high beams work fine. The plow came off a 2004 silverado, and I thought everything would hook right up? If what you allude to below is my issue, do I just need to switch something on the ISO module, or be changing wires on the harness at the headlights???

     
  16. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Well is it the same light harness? Did you look on westerns website to make sure its the same? Make sure it is and let's start there
     
  17. brettz28

    brettz28 Junior Member
    Messages: 20

    I did look at that and it showed the same harness. The thing is I had to kind of make some assumptions because western does not show this plow on a tahoe.

    It is doing the same type of thing as my Sierra did the last couple of years, bt then I knew the harness was incorrect. I did not know of this site at the time, so I just used the high beam plow lights and adjusted them down.
     
  18. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Ok if its the same. Ck the pwr and gnd and see which one is switched. Then on the western side there's an a and b side. Plug the connector in the right way
     
  19. brettz28

    brettz28 Junior Member
    Messages: 20

    This is where I am losing you, am I switch the wires at the headlights or changing plugs at the ISO module
     
  20. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,977

    Headlights. Only. The factory tk connectors to the western connectors