1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow light problems

Discussion in 'Truck & Equipment Repair' started by 603chevy551, Sep 21, 2014.

  1. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    Can anyone help me out I just got my plow wired up and I connect it and only the high beams work. I have no low beams, turn signals or running lights. I have a Fisher MM2 3 plug, 4 port 8' HD. It's mounted on to a 2001 Chevy 2500HD, the plow and truck side were purchased used and installed professionally
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,924

    No turn signals on the plow or trk?
     
  3. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    the turn signals work on the truck and don't work on the plow.
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,924

    Ok. Start tracing wires. Start at the trk parking lights, Ck where you spliced in for the plow.
     
  5. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    OK thanks for the tip do you know where I could find a wiring diagram
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,924

    Fisheplows.com. library, look for 3 and 4 port module's
    Or look for the most downloaded and you might find it
     
  7. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    Running lights work and turn signals too, it was a blown fuse, but left on truck turn right on plow and vise versa. But still no low beams I'm going keep working at it.
     
  8. ScubaSteve728

    ScubaSteve728 Senior Member
    Messages: 477

    check the light plugs clean them out with a pipe cleaner and wire brush and then degrease them and after that trace the grounds
     
  9. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    Switch the plugs at the number 3 & 4 positions on the isolation module. That should fix this issue, but if they've actually got the plug-in harnesses routed to the wrong sides of the truck, you may lose your parking lights. If so, you'll have to swap them from one side of the truck to the other. Or... they installed the wrong plug in harnesses all together. Is there any part number tags on the harnesses in the number 3 & 4 positions. What color label on your isolation module?
     
  10. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    The harness as part number 26290 on one cable and 26291 on the other the module is green
     
  11. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    The whole truck side kit came off of a 06 GMC 2500HD
     
  12. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    Any other numbers on the tags? 26360, 26361, 26351, 26352?
     
  13. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    That's your problem... you've got 26351 & 26352 plug in harnesses. You need 26360 & 26361.

    2006 is negative common. 2001 is positive common.

    Your harnesses can be re-pinned if you have a little ability.

    That's why your low beams don't work anyway. As far as the directionals... they've probably just got the harnesses swapped.

    So much for the stuff being "professionally" installed... :)
     
    Last edited: Sep 21, 2014
  14. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    I can't see any other part number but the part numbers on the module is 27779 and 27781
     
  15. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    The module is fine. It's the plug-in harnesses that are wrong (3&4)
     
  16. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

  17. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    Do I need to replace the harness or just swap 3 & 4
     
  18. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    You need to read the thread that I posted the link to. It shows exactly what needs to be done to fix the low beams.

    As far as the turn signals... the shorter of the two plug in harnesses will have a brown wire which is spliced into the truck's parking lights. It needs to go to the driver's side truck headlamp, and be plugged into the #3 position on the module. If it's spliced into the passenger's side, you'll need to move it to the driver's side. If it's spliced into the driver's side, but it's plugged into the #4 port, it just needs to be swapped to #3.

    EDIT: If the parking lights are working on the plow, but the directionals are opposite from the truck, then they've got the harnesses run to the wrong sides of the truck.
     
    Last edited: Sep 21, 2014
  19. 603chevy551

    603chevy551 Junior Member
    Messages: 11

    Parking light work and the brown wire is spliced into drivers side so all I hat to do is swap 3 and 4 at the module like your post said. I read the link and will swap the wires like what that thread said for low beams