1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow Light Problems W/ Pro Plus

Discussion in 'Western Plows Discussion' started by HOOBS PRO PLUS, Jan 13, 2008.

  1. HOOBS PRO PLUS

    HOOBS PRO PLUS Member
    from NW PA
    Messages: 45

    Anyone have any suggestions why My Plow Lights won't work? I only have the long harness connected as I am waiting for the short one to come in but the dealer said the one light would still work. I plugged the long harness into the #4 port in the iso. and plugged the headlight into the adapter. Please Help snow on the way!!!
     
  2. itsgottobegreen

    itsgottobegreen PlowSite.com Addict
    Messages: 1,351

    If this is on your 08, they should have sold you a 3 port with the relay jumper kit to make the high low work. A pic of what you have under the hood would be great.
     
  3. HOOBS PRO PLUS

    HOOBS PRO PLUS Member
    from NW PA
    Messages: 45

    I have the 4 port white label Iso. So this set up won't work? I found this polw in the paper for a super price and thought I'd save some $$ putting it on myself and it's turned out tobe a nightmare!!! The Dealer said nothing about needing a new Iso. Mod. Can't post Pic will try to have one of my guys take a picture and post later.
     
  4. HOOBS PRO PLUS

    HOOBS PRO PLUS Member
    from NW PA
    Messages: 45

    Got everything hooked up like it should be and now everything works but the plow lights!! And when I disconnect the plow the left truck headlight won't work!!! Does anyone have any suggestions???
     
  5. itsgottobegreen

    itsgottobegreen PlowSite.com Addict
    Messages: 1,351

    Check your PM