1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow light problem

Discussion in 'Commercial Snow Removal' started by Mick, Nov 24, 2002.

  1. Mick

    Mick PlowSite.com Veteran
    from Maine
    Messages: 5,546

    Well, anyone have any ideas? Passenger side low beam went out on the plow light (Fisher MM). High beam works fine. Other side works fine. Changed headlight - still the same low beam is out. Disconnect and truck lights work fine. All the rest of the electrical seems to be working ok, no frayed wires that I can see. Unrelated, I think, but the son just had a new battery put in. It's not as big as the other one and seemed to discharge more when I was plowing so I told him I want a bigger battery.

    Anybody have any ideas before I take it into the shop? Although I know how, I'm not into repairs. Changing the headlight was more than I really wanted to do.:(
     
  2. CT18fireman

    CT18fireman Banned
    Messages: 2,133

    Check all the pins in the connection to make sure they are not bent. What light system? The new e-force is pretty complicated.
     
  3. Mick

    Mick PlowSite.com Veteran
    from Maine
    Messages: 5,546

    That might very well be it. Thanks. I'll take a look, but I imagine either way - to the shop it goes.
     
  4. Mick

    Mick PlowSite.com Veteran
    from Maine
    Messages: 5,546

    Hey, thanks, CT18fireman. That was it. Pin right in the corner. Bent it back with my fingernail. Less than a minute and works like a charm.

    I thought you were serious about it being complicated
    :eek: :eek: :eek: .