1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow headlights not working

Discussion in 'Ram Trucks' started by steveb92, Dec 9, 2009.

  1. steveb92

    steveb92 Junior Member
    from RI
    Messages: 5

    I have a 99 Dodge Ram 1500 with a MM1 2 plug setup. The parking lights work on the plow but headlights do not. I do notice the relays click when I plug and unplug the cable. After the unplugging the parking light no longer work and my dash light are now out. Not sure what the isue could be. If a part is needed where can one be purchased. Thanks.
     
  2. Sonic Buzz

    Sonic Buzz Member
    Messages: 38

    did u check fuses
     
  3. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    New install or existing ?
     
  4. steveb92

    steveb92 Junior Member
    from RI
    Messages: 5

    Thanks guys

    This is an existing install and I did check the fuses, all look good but will double check later today. I noticed the relays have alot of corosion on them so I tried to clean the an dbroke 1 tab(go figure) so I will have to replace at least one of those, or just plow during the daytime. :)
     
  5. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    Replace them all to eliminate the relays. There is a way to test them if your so inclined...

    My other thought is...where did you get your light harness for the truck?



    <object width="560" height="340"><param name="movie" value="http://www.youtube.com/v/3JB63ebFfgU&hl=en_US&fs=1&rel=0"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/3JB63ebFfgU&hl=en_US&fs=1&rel=0" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="560" height="340"></embed></object>
     
  6. steveb92

    steveb92 Junior Member
    from RI
    Messages: 5

    This was in the truck when I got it, worked fine last winter but sat most the year with minimal use. Do you know where I can buy new relay's?
     
  7. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    Oh yeah, I don't know what I was thinking, you already said that.

    Relays...Napa, any auto parts store.
     
  8. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    Have you tried new bulbs?
    If yes do the truck headlights work?
     
  9. steveb92

    steveb92 Junior Member
    from RI
    Messages: 5

    truck head lights work as soon as I unplug the plow??
     
  10. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    To clarify.... The 29400-2 is what you have. or more specifically 29499, here is the excerpt

    uyuy.jpg

    uyuy.jpg
     
  11. steveb92

    steveb92 Junior Member
    from RI
    Messages: 5

    Really good questions I will check after work not to sure.
     
  12. SamWJones13

    SamWJones13 Member
    Messages: 30

    I'm having basically the same problem with my Boss 7'6" super duty on a '96 Ram 2500. The plow was installed a couple months ago and the plow lights worked until (of course) two nights ago when I needed to go plow snow. My truck lights have been acting up here and there but some jiggling on the on off switch would turn them on usually. By the end of the night, only amber lights were working on the truck or plow. I replaced the truck on off switch and the wiring harness, which was fried. The truck lights now work fine and I was hoping that would fix the plow light problem but the amber lights are still all that work on the plow. Any ideas??? I'm pretty good with mechanical issues but wiring problems still confuse me a bit.
     
  13. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    Yes....I have an idea. Go start your own thread in the BOSS section. That way when others come through this thread in the future to try an correct there similar issues with there similar plows, there not going to get confused and sidetracked onto other issues...especially were your talking about a totally different plow.

    You'll also get alot more product specific help there as well.