1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow E47 Leaking

Discussion in 'Meyer / Diamond Products Discussion' started by ToddM NJ, Jan 4, 2014.

  1. ToddM NJ

    ToddM NJ Member
    Messages: 45

    My Meyers E-47 pump is leaking between the sump base and the PA Block. However, it only leaks when moving left and right and vice versus. When I move up and down and its sitting it does not leak. I was thinking it could have a crack in the sump base but if was that I figured it would leak all the time. Someone please help me.
     
  2. Fourtrax250R

    Fourtrax250R Senior Member
    Messages: 109

    there are 3 O-rings that seal the P/A block to the sump base... one or more of them could have gone bad... there are 4 allen bolts on the outside of the P/A block... remove those and the block will come free.. you will see the 3 o-rings I'm talking about..... VERY easy to replace.... hopefully that's it and you don't in fact have a crack in the sump base/block. There are multiple website you can get the O-rings at.. good luck!
     
  3. ToddM NJ

    ToddM NJ Member
    Messages: 45

    Just replaced those three rings and still does it. I looked at the sump but could not see any cracks. It is weird it only leaks when going left to right and vice versus. Could it be anything else?
     
  4. Fourtrax250R

    Fourtrax250R Senior Member
    Messages: 109

    A lot of times the cracks are so small they are hard to see....have you had water inside the pump recently? When it freezes it expands and can crack the sump base/the fluid passages. You probably have a small crack somewhere. Is that the original pump that came on your 89 ram?
     
  5. ToddM NJ

    ToddM NJ Member
    Messages: 45

    I am not sure if it is the original with the truck. When I bought the truck three years ago it had the pump on it. Why would it leak when only going left to right and not up and down?
     
  6. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,691

    Are sure it is not coming out of the bolt on the bottom?
     
  7. JeepCoMJ

    JeepCoMJ Senior Member
    Messages: 284

    Was the angle block corroded around where the Orings seat? I have seen them corrode and have an undercut around each o ring so bad that they just will not seal anymore.
     
  8. crete5245

    crete5245 Member
    Messages: 61

    Had something similar on one but it leaked any time. replace the seals and looked at the block and the area around the seals looked good, but it was corroded very badly every where else, put a new block on and it stopped leaking.

    I was wondering if one of those seated balls could be leaking.

    I am going to have my machine shop class mill off about .015 of a inch to see if that helps.

    My question to you kimber and jeep, will that hurt the block.
     
  9. ToddM NJ

    ToddM NJ Member
    Messages: 45

    What bolt on the bottom? The block didn't look bad at all.
     
  10. ToddM NJ

    ToddM NJ Member
    Messages: 45

    Looks like it is leaking from crossover valve.