1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow Angle

Discussion in 'Western Plows Discussion' started by GLSCPE, Dec 22, 2006.

  1. GLSCPE

    GLSCPE Junior Member
    Messages: 13

    My Western Ultra Mount will not angle, but goes up and down fine. Any ideas?
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    First thing to check is your grill connector's.Make sure the electrical pin's are clean and corrosion free and making good contact.When you try to angle it does the motor run but the plow doesn't move?
     
  3. GLSCPE

    GLSCPE Junior Member
    Messages: 13

    That is correct, it trys to angle but it doesn't move
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Ok, If you checked your grill connector and it's clean and free of corrosion then the next thing to do is see if the S2 coil on the pump is getting power when you try to angle it.For the blade to angle in either direction the S2 coil and valve has to operate.Pull the coil cover off the pump and using a test light check the S2 coil for power while someone holds the control in the angle position.The S2 coil is the one in the middle of the three coil's.It'll have a light green wire.
     
  5. GLSCPE

    GLSCPE Junior Member
    Messages: 13

    That was the problem, installed new S2 and it is working fine. THanks!
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Glad to hear you got it fixed! Congrat's! purplebou BTW I see your from central Pa too, Where are you located?