1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow angle problem

Discussion in 'Commercial Snow Removal' started by Michael F, Dec 29, 2000.

  1. Michael F

    Michael F Senior Member
    Messages: 203

    I just backed my F350 into garage, angled blade, it won't angle back. Called driver for that truck asked him how it worked, he said fine-no problems. The last site he was at had concrete curbs, wondering if check valve got stuck. Pump is an under the hood haynes, bran new that was first storm on it. HELP, were supposed to get 12+inches over next couple days, if I don't get it fixed I'll be in truck 12 hrs per run, figuring on three runs.
  2. Mark Oomkes

    Mark Oomkes PlowSite Fanatic
    Messages: 10,468

    If it has quick connects try replacing those--sometimes they go bad even if they look OK. That's the easiest thing to start with. Otherwise maybe the cylinder is bad (from hitting curbs) or the like you said there might be dirt in the valve.
  3. Michael F

    Michael F Senior Member
    Messages: 203

    Found the problem. A wire that has a spade conecter on it, spade conecter female side was streched out and slipped off. I crimped it and put it back together, work fine now. Amen, all ready for snow, just have to check fluids, clean windows, ready to run.